dev-ros/depth_image_proc: Fix build with gcc6.
authorAlexis Ballier <aballier@gentoo.org>
Mon, 23 Jan 2017 12:20:38 +0000 (13:20 +0100)
committerAlexis Ballier <aballier@gentoo.org>
Mon, 23 Jan 2017 12:28:12 +0000 (13:28 +0100)
Package-Manager: Portage-2.3.3, Repoman-2.3.1

dev-ros/depth_image_proc/depth_image_proc-1.12.19.ebuild
dev-ros/depth_image_proc/files/gcc6.patch [new file with mode: 0644]

index 99fb96f964f95f6024cae52ab371f763c8c9e8fc..f88651c40928b4ac070a177a66affdf8173c09d6 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
@@ -27,3 +27,4 @@ RDEPEND="
        dev-ros/tf2_ros
 "
 DEPEND="${RDEPEND}"
+PATCHES=( "${FILESDIR}/gcc6.patch" )
diff --git a/dev-ros/depth_image_proc/files/gcc6.patch b/dev-ros/depth_image_proc/files/gcc6.patch
new file mode 100644 (file)
index 0000000..694e2a1
--- /dev/null
@@ -0,0 +1,35 @@
+commit 6c2d65452bd5fe62723988a1a570789921900d59
+Author: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
+Date:   Fri Sep 30 15:39:47 2016 +0200
+
+    address gcc6 build error
+    
+    With gcc6, compiling fails with `stdlib.h: No such file or directory`,
+    as including '-isystem /usr/include' breaks with gcc6, cf.,
+    https://gcc.gnu.org/bugzilla/show_bug.cgi?id=70129.
+    
+    This commit addresses this issue for this package in the same way
+    it was addressed in various other ROS packages. A list of related
+    commits and pull requests is at:
+    
+      https://github.com/ros/rosdistro/issues/12783
+    
+    Signed-off-by: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
+
+diff --git a/depth_image_proc/CMakeLists.txt b/depth_image_proc/CMakeLists.txt
+index 0a7c7e2..6ceebfe 100644
+--- a/depth_image_proc/CMakeLists.txt
++++ b/depth_image_proc/CMakeLists.txt
+@@ -10,11 +10,7 @@ catkin_package(
+ find_package(Boost REQUIRED)
+ find_package(Eigen REQUIRED)
+ find_package(OpenCV REQUIRED)
+-include_directories(include
+-        SYSTEM ${BOOST_INCLUDE_DIRS}
+-               ${catkin_INCLUDE_DIRS}
+-               ${EIGEN_INCLUDE_DIRS}
+-)
++include_directories(include ${BOOST_INCLUDE_DIRS} ${catkin_INCLUDE_DIRS} ${EIGEN_INCLUDE_DIRS})
+ add_library(${PROJECT_NAME} src/nodelets/convert_metric.cpp
+                              src/nodelets/crop_foremost.cpp