media-sound/aqualung: fix build with ffmpeg git master.
authorAlexis Ballier <aballier@gentoo.org>
Wed, 16 Sep 2015 16:43:29 +0000 (18:43 +0200)
committerAlexis Ballier <aballier@gentoo.org>
Wed, 16 Sep 2015 16:45:01 +0000 (18:45 +0200)
Package-Manager: portage-2.2.20.1

media-sound/aqualung/aqualung-1.0.ebuild
media-sound/aqualung/files/ffmpeg29.patch [new file with mode: 0644]

index b39de6ca08d2ccdcd5cb4901a9cd1fdac6508585..c6954bef5a2c671d5a087e51e1f80e04ea291887 100644 (file)
@@ -50,6 +50,10 @@ DEPEND="${RDEPEND}
 
 S=${WORKDIR}/${PN}-${MY_PV}
 
+src_prepare() {
+       epatch "${FILESDIR}/ffmpeg29.patch"
+}
+
 src_configure() {
        econf \
                --enable-nls \
diff --git a/media-sound/aqualung/files/ffmpeg29.patch b/media-sound/aqualung/files/ffmpeg29.patch
new file mode 100644 (file)
index 0000000..3cd0a01
--- /dev/null
@@ -0,0 +1,13 @@
+Index: aqualung-1.0/src/decoder/dec_lavc.c
+===================================================================
+--- aqualung-1.0.orig/src/decoder/dec_lavc.c
++++ aqualung-1.0/src/decoder/dec_lavc.c
+@@ -280,7 +280,7 @@ lavc_decoder_open(decoder_t * dec, char
+               return DECODER_OPEN_BADLIB;
+       pd->avCodecCtx = pd->avFormatCtx->streams[pd->audioStream]->codec;
+-#if LIBAVCODEC_VERSION_MAJOR >= 53
++#if LIBAVCODEC_VERSION_MAJOR >= 53 && LIBAVCODEC_VERSION_MAJOR < 57
+       pd->avCodecCtx->get_buffer = avcodec_default_get_buffer;
+       pd->avCodecCtx->release_buffer = avcodec_default_release_buffer;
+ #endif /* LIBAVCODEC_VERSION_MAJOR >= 53 */