Version bump. Fixes 2 security issues with modelines and other bugs.
authorMike Kelly <pioto@gentoo.org>
Sun, 29 Apr 2007 22:28:28 +0000 (22:28 +0000)
committerMike Kelly <pioto@gentoo.org>
Sun, 29 Apr 2007 22:28:28 +0000 (22:28 +0000)
Package-Manager: portage-2.1.2.5

app-editors/gvim/ChangeLog
app-editors/gvim/files/digest-gvim-7.0.235 [new file with mode: 0644]
app-editors/gvim/gvim-7.0.235.ebuild [new file with mode: 0644]
app-editors/vim-core/ChangeLog
app-editors/vim-core/files/digest-vim-core-7.0.235 [new file with mode: 0644]
app-editors/vim-core/vim-core-7.0.235.ebuild [new file with mode: 0644]
app-editors/vim/ChangeLog
app-editors/vim/files/digest-vim-7.0.235 [new file with mode: 0644]
app-editors/vim/vim-7.0.235.ebuild [new file with mode: 0644]

index 2b004d466f96b581c721fdd8e0b2763251419d81..8a2bfdfa9cd74b7b4dfd6bdc9f16583f935758fe 100644 (file)
@@ -1,6 +1,9 @@
 # ChangeLog for app-editors/gvim
 # Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/gvim/ChangeLog,v 1.221 2007/03/21 16:03:48 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gvim/ChangeLog,v 1.222 2007/04/29 22:28:28 pioto Exp $
+
+  29 Apr 2007; Mike Kelly <pioto@gentoo.org> +gvim-7.0.235.ebuild:
+  Version bump. Fixes 2 security issues with modelines and other bugs.
 
   21 Mar 2007; Chris Gianelloni <wolf31o2@gentoo.org> gvim-7.0.174.ebuild:
   Stable on alpha/ia64 wrt bug #167816.
diff --git a/app-editors/gvim/files/digest-gvim-7.0.235 b/app-editors/gvim/files/digest-gvim-7.0.235
new file mode 100644 (file)
index 0000000..b4de19d
--- /dev/null
@@ -0,0 +1,9 @@
+MD5 a55e36b3c7a21a5835a35574d1f6595e vim-7.0-gentoo-patches-r1.tar.bz2 6749
+RMD160 88cead14b07bc3b7113a3e60f2b358caf501c789 vim-7.0-gentoo-patches-r1.tar.bz2 6749
+SHA256 17934badbe1288149a31ac309c17b579a0c33a409b5928a759620631c4a1ec7c vim-7.0-gentoo-patches-r1.tar.bz2 6749
+MD5 e8c8bb2b5c03f49d40e9736b7d479b9b vim-7.0-r1.tar.bz2 6117202
+RMD160 d24982a1b802dad9955940365665163a4641fd74 vim-7.0-r1.tar.bz2 6117202
+SHA256 e7383b2dfdc6f6df52fb45599eb6c5dc9037b1d3a4077bfe770cb98440b2589e vim-7.0-r1.tar.bz2 6117202
+MD5 c8dc25c06ecee41f9eaae088f3012103 vim-patches-7.0.235.tar.gz 343289
+RMD160 c54e63fbc74250e95d2ba242a66cea99ffffeff1 vim-patches-7.0.235.tar.gz 343289
+SHA256 0833aae00440155a6b5c507ecdcc00b743889c578b47a967fc4ae9ea456d5779 vim-patches-7.0.235.tar.gz 343289
diff --git a/app-editors/gvim/gvim-7.0.235.ebuild b/app-editors/gvim/gvim-7.0.235.ebuild
new file mode 100644 (file)
index 0000000..fc0e993
--- /dev/null
@@ -0,0 +1,45 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gvim/gvim-7.0.235.ebuild,v 1.1 2007/04/29 22:28:28 pioto Exp $
+
+inherit vim
+
+VIM_VERSION="7.0"
+VIM_SNAPSHOT="vim-7.0-r1.tar.bz2"
+VIM_GENTOO_PATCHES="vim-7.0-gentoo-patches-r1.tar.bz2"
+VIM_ORG_PATCHES="vim-patches-${PV}.tar.gz"
+GVIMRC_FILE_SUFFIX="-r1"
+
+SRC_URI="${SRC_URI}
+       mirror://gentoo/${VIM_SNAPSHOT}
+       mirror://gentoo/${VIM_GENTOO_PATCHES}
+       mirror://gentoo/${VIM_ORG_PATCHES}"
+
+S=${WORKDIR}/vim${VIM_VERSION/.*}
+DESCRIPTION="GUI version of the Vim text editor"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="aqua gnome gtk motif nextaw"
+PROVIDE="virtual/editor"
+DEPEND="${DEPEND}
+       ~app-editors/vim-core-${PV}
+       || ( x11-libs/libXext virtual/x11 )
+       !aqua? (
+               gtk? (
+                       >=x11-libs/gtk+-2.6
+                       virtual/xft
+                       gnome? ( >=gnome-base/libgnomeui-2.6 )
+               )
+               !gtk? (
+                       motif? (
+                               x11-libs/openmotif
+                       )
+                       !motif? (
+                               nextaw? (
+                                       x11-libs/neXtaw
+                               )
+                               !nextaw? (
+                                       || ( x11-libs/libXaw virtual/x11 )
+                               )
+                       )
+               )
+       )"
index 1c23e5cbbd2079fe3e7e25ac8ff00358ed46b610..091ec9efb45b975f9422e0325703512c8c614e28 100644 (file)
@@ -1,6 +1,9 @@
 # ChangeLog for app-editors/vim-core
 # Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/vim-core/ChangeLog,v 1.244 2007/03/21 16:02:32 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/vim-core/ChangeLog,v 1.245 2007/04/29 22:25:51 pioto Exp $
+
+  29 Apr 2007; Mike Kelly <pioto@gentoo.org> +vim-core-7.0.235.ebuild:
+  Version bump. Fixes 2 security issues with modelines and other bugs.
 
   21 Mar 2007; Chris Gianelloni <wolf31o2@gentoo.org>
   vim-core-7.0.174.ebuild:
diff --git a/app-editors/vim-core/files/digest-vim-core-7.0.235 b/app-editors/vim-core/files/digest-vim-core-7.0.235
new file mode 100644 (file)
index 0000000..b4de19d
--- /dev/null
@@ -0,0 +1,9 @@
+MD5 a55e36b3c7a21a5835a35574d1f6595e vim-7.0-gentoo-patches-r1.tar.bz2 6749
+RMD160 88cead14b07bc3b7113a3e60f2b358caf501c789 vim-7.0-gentoo-patches-r1.tar.bz2 6749
+SHA256 17934badbe1288149a31ac309c17b579a0c33a409b5928a759620631c4a1ec7c vim-7.0-gentoo-patches-r1.tar.bz2 6749
+MD5 e8c8bb2b5c03f49d40e9736b7d479b9b vim-7.0-r1.tar.bz2 6117202
+RMD160 d24982a1b802dad9955940365665163a4641fd74 vim-7.0-r1.tar.bz2 6117202
+SHA256 e7383b2dfdc6f6df52fb45599eb6c5dc9037b1d3a4077bfe770cb98440b2589e vim-7.0-r1.tar.bz2 6117202
+MD5 c8dc25c06ecee41f9eaae088f3012103 vim-patches-7.0.235.tar.gz 343289
+RMD160 c54e63fbc74250e95d2ba242a66cea99ffffeff1 vim-patches-7.0.235.tar.gz 343289
+SHA256 0833aae00440155a6b5c507ecdcc00b743889c578b47a967fc4ae9ea456d5779 vim-patches-7.0.235.tar.gz 343289
diff --git a/app-editors/vim-core/vim-core-7.0.235.ebuild b/app-editors/vim-core/vim-core-7.0.235.ebuild
new file mode 100644 (file)
index 0000000..f5871b3
--- /dev/null
@@ -0,0 +1,23 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/vim-core/vim-core-7.0.235.ebuild,v 1.1 2007/04/29 22:25:51 pioto Exp $
+
+inherit vim
+
+VIM_VERSION="7.0"
+VIM_SNAPSHOT="vim-7.0-r1.tar.bz2"
+VIM_GENTOO_PATCHES="vim-7.0-gentoo-patches-r1.tar.bz2"
+VIM_ORG_PATCHES="vim-patches-${PV}.tar.gz"
+VIMRC_FILE_SUFFIX="-r3"
+
+SRC_URI="${SRC_URI}
+       mirror://gentoo/${VIM_SNAPSHOT}
+       mirror://gentoo/${VIM_GENTOO_PATCHES}
+       mirror://gentoo/${VIM_ORG_PATCHES}"
+
+S=${WORKDIR}/vim${VIM_VERSION/.*}
+DESCRIPTION="vim and gvim shared files"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE=""
+DEPEND="${DEPEND}"
+PDEPEND="!livecd? ( app-vim/gentoo-syntax )"
index f583d29ff4d492aba1036ff739ede98c7210c2f1..d1d8727662e5e07cd8712f8a87e7d04a70a96e0f 100644 (file)
@@ -1,6 +1,9 @@
 # ChangeLog for app-editors/vim
 # Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/vim/ChangeLog,v 1.261 2007/03/21 16:04:02 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/vim/ChangeLog,v 1.262 2007/04/29 22:27:26 pioto Exp $
+
+  29 Apr 2007; Mike Kelly <pioto@gentoo.org> +vim-7.0.235.ebuild:
+  Version bump. Fixes 2 security issues with modelines and other bugs.
 
   21 Mar 2007; Chris Gianelloni <wolf31o2@gentoo.org> vim-7.0.174.ebuild:
   Stable on alpha/ia64 wrt bug #167816.
diff --git a/app-editors/vim/files/digest-vim-7.0.235 b/app-editors/vim/files/digest-vim-7.0.235
new file mode 100644 (file)
index 0000000..b4de19d
--- /dev/null
@@ -0,0 +1,9 @@
+MD5 a55e36b3c7a21a5835a35574d1f6595e vim-7.0-gentoo-patches-r1.tar.bz2 6749
+RMD160 88cead14b07bc3b7113a3e60f2b358caf501c789 vim-7.0-gentoo-patches-r1.tar.bz2 6749
+SHA256 17934badbe1288149a31ac309c17b579a0c33a409b5928a759620631c4a1ec7c vim-7.0-gentoo-patches-r1.tar.bz2 6749
+MD5 e8c8bb2b5c03f49d40e9736b7d479b9b vim-7.0-r1.tar.bz2 6117202
+RMD160 d24982a1b802dad9955940365665163a4641fd74 vim-7.0-r1.tar.bz2 6117202
+SHA256 e7383b2dfdc6f6df52fb45599eb6c5dc9037b1d3a4077bfe770cb98440b2589e vim-7.0-r1.tar.bz2 6117202
+MD5 c8dc25c06ecee41f9eaae088f3012103 vim-patches-7.0.235.tar.gz 343289
+RMD160 c54e63fbc74250e95d2ba242a66cea99ffffeff1 vim-patches-7.0.235.tar.gz 343289
+SHA256 0833aae00440155a6b5c507ecdcc00b743889c578b47a967fc4ae9ea456d5779 vim-patches-7.0.235.tar.gz 343289
diff --git a/app-editors/vim/vim-7.0.235.ebuild b/app-editors/vim/vim-7.0.235.ebuild
new file mode 100644 (file)
index 0000000..b303282
--- /dev/null
@@ -0,0 +1,26 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/vim/vim-7.0.235.ebuild,v 1.1 2007/04/29 22:27:26 pioto Exp $
+
+inherit vim
+
+VIM_VERSION="7.0"
+VIM_SNAPSHOT="vim-7.0-r1.tar.bz2"
+VIM_GENTOO_PATCHES="vim-7.0-gentoo-patches-r1.tar.bz2"
+VIM_ORG_PATCHES="vim-patches-${PV}.tar.gz"
+
+SRC_URI="${SRC_URI}
+       mirror://gentoo/${VIM_SNAPSHOT}
+       mirror://gentoo/${VIM_GENTOO_PATCHES}
+       mirror://gentoo/${VIM_ORG_PATCHES}"
+
+S=${WORKDIR}/vim${VIM_VERSION/.*}
+DESCRIPTION="Vim, an improved vi-style text editor"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE=""
+PROVIDE="virtual/editor"
+DEPEND="${DEPEND}
+       !minimal? ( ~app-editors/vim-core-${PV} )"
+RDEPEND="${RDEPEND}
+       !<app-editors/nvi-1.81.5-r4
+       !minimal? ( ~app-editors/vim-core-${PV} )"