dev-java/jfreesvg: Raise {jdk,jre} reqs to 1.7. Fixes bug 559962.
authorPatrice Clement <monsieurp@gentoo.org>
Thu, 10 Sep 2015 14:21:28 +0000 (14:21 +0000)
committerPatrice Clement <monsieurp@gentoo.org>
Thu, 10 Sep 2015 14:23:19 +0000 (14:23 +0000)
Package-Manager: portage-2.2.18
Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
dev-java/jfreesvg/jfreesvg-2.1-r1.ebuild [new file with mode: 0644]

diff --git a/dev-java/jfreesvg/jfreesvg-2.1-r1.ebuild b/dev-java/jfreesvg/jfreesvg-2.1-r1.ebuild
new file mode 100644 (file)
index 0000000..ea0116c
--- /dev/null
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="JFreeSVG is a fast, light-weight, vector graphics library for the Java platform"
+HOMEPAGE="http://www.jfree.org/jfreesvg/"
+SRC_URI="mirror://sourceforge/jfreegraphics2d/${P}.zip"
+
+LICENSE="GPL-3"
+SLOT="2.1"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug"
+
+DEPEND=">=virtual/jdk-1.7
+       app-arch/unzip"
+RDEPEND=">=virtual/jre-1.7"
+
+java_prepare() {
+       find "${WORKDIR}" -name '*.jar' -print -delete || die
+}
+
+src_compile() {
+       if ! use debug; then
+               antflags="-Dbuild.debug=false -Dbuild.optimize=true"
+       fi
+       eant -f ant/build.xml compile $(use_doc) $antflags
+}
+
+src_install() {
+       java-pkg_newjar "./lib/${P}.jar" ${PN}.jar
+       dodoc README.md
+       use doc && java-pkg_dojavadoc javadoc
+       use source && java-pkg_dosrc src/main/java
+}