net-libs/zeromq: Bump to v4.2.0
authorThomas Deutschmann <whissi@gentoo.org>
Sat, 10 Dec 2016 01:25:47 +0000 (02:25 +0100)
committerThomas Deutschmann <whissi@gentoo.org>
Sat, 10 Dec 2016 01:28:22 +0000 (02:28 +0100)
Package-Manager: portage-2.3.2

net-libs/zeromq/Manifest
net-libs/zeromq/metadata.xml
net-libs/zeromq/zeromq-4.2.0.ebuild [new file with mode: 0644]

index 8d2a8bdff2fec12e2cf0d565a4179485a82444bf..16265e7c261fbcef420f31174a610e183ca8ae15 100644 (file)
@@ -5,3 +5,4 @@ DIST zeromq-4.1.1.tar.gz 1383196 SHA256 43d61e5706b43946aad4a661400627bcde9c63cc
 DIST zeromq-4.1.4.tar.gz 1400012 SHA256 e99f44fde25c2e4cb84ce440f87ca7d3fe3271c2b8cfbc67d55e4de25e6fe378 SHA512 8a8cf4f52ad78dddfff104bfba0f80bbc12566920906a0fafb9fc340aa92f5577c2923cb2e5346c69835cd2ea1609647a8893c2883cd22c1f0340a720511460c WHIRLPOOL ef7a700ab732cb319dbc3647184710bcc0f7d265b92d3e97b5e3ae393a4e055d9530de48fadf369c705e68bcfbd4c4c592db1e1f081e6fbe18eff12a9d74a83c
 DIST zeromq-4.1.5.tar.gz 794853 SHA256 04aac57f081ffa3a2ee5ed04887be9e205df3a7ddade0027460b8042432bdbcf SHA512 b5098e7ea7fe7fdae75846a804d175bcb414a4f8212a15b9c1c2e52f3541aa603e773061db7ea92075e1f9f9be40572aba1c133b233a8ac2458bccf8427e407e WHIRLPOOL c87306413e7f8cad56fb53b135331d388ec4830a6eff63e4c4cf29bc4db7c819e628ebf7771dbf39b223ce0cc32f7bc725157475880582a0448ca8ab7112497f
 DIST zeromq-4.1.6.tar.gz 799771 SHA256 02ebf60a43011e770799336365bcbce2eb85569e9b5f52aa0d8cc04672438a0a SHA512 c04a6bb7a719687d8e8e5e8a103f93ab75ead3fcd3516e6089959e4f02cff7c18e9d7a8696af4245d434b45e6aa6e2ca8f73d98db058df621bca3def97bf7af1 WHIRLPOOL 5c266d2f257584a606f7ec1d4d00a5c2d7a636814f33ce2a1bfd19a4ca650c5fa86527d70948bb4e04b20bd5e068ffd29a2bf63f9979459bf825c23e55340abb
+DIST zeromq-4.2.0.tar.gz 1046254 SHA256 53b83bf0ee978931f76fa9cb46ad4affea65787264a5f3d140bc743412d0c117 SHA512 3b6f0a1869fb1663ea40b3c3aa088b81399a35c051e4ade2b30bbac60bfceefe6b4403248a4635fb31d33767c1e478342f61c47b0ffdb4501419c13590ebeb96 WHIRLPOOL 432a8b04a28bd371a85c79dfd79d498808af8afe0e4d8b9bd903eef9d4f5e9c09c165484ee651b1a54e2e416bb324e39bee2db3a5880e216a7472c56c6e64190
index 28962275ceb874a2df80077fa135f1a26967c0ba..981328e740da37c6d66e234439469d9626b62ca3 100644 (file)
@@ -11,8 +11,9 @@
                        <name>Martin Sustrik</name>
                </maintainer>
                <doc>http://zguide.zeromq.org/page:all</doc>
-               <bugs-to>https://github.com/zeromq/zeromq4-1/issues</bugs-to>
+               <bugs-to>https://github.com/zeromq/libzmq/issues</bugs-to>
                <remote-id type="github">zeromq/zeromq4-1</remote-id>
+               <remote-id type="github">zeromq/libzmq</remote-id>
        </upstream>
        <longdescription lang="en">
                The 0MQ lightweight messaging kernel is a library which
                (subscriptions), seamless access to multiple transport protocols
                and more.
        </longdescription>
+       <slots>
+               <subslots>Reflect ABI of libzmq.so.</subslots>
+       </slots>
        <use>
                <flag name="pgm">
                        Build PGM (Pragmatic General Multicast)extention, a protocol for reliable 
                        multicast transport of data over IP networks.
                </flag>
+               <flag name="sodium">
+                       Use <pkg>dev-libs/libsodium</pkg> for cryptography
+               </flag>
        </use>
 </pkgmetadata>
diff --git a/net-libs/zeromq/zeromq-4.2.0.ebuild b/net-libs/zeromq/zeromq-4.2.0.ebuild
new file mode 100644 (file)
index 0000000..f43dcbd
--- /dev/null
@@ -0,0 +1,55 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+
+inherit autotools
+
+DESCRIPTION="A brokerless kernel"
+HOMEPAGE="http://www.zeromq.org/"
+SRC_URI="https://github.com/zeromq/libzmq/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0/5"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="pgm +sodium static-libs test"
+
+RDEPEND="
+       sodium? ( dev-libs/libsodium:= )
+       pgm? ( =net-libs/openpgm-5.2.122 )"
+DEPEND="${RDEPEND}
+       app-text/asciidoc
+       app-text/xmlto
+       sys-apps/util-linux
+       pgm? ( virtual/pkgconfig )"
+
+src_prepare() {
+       sed \
+               -e '/libzmq_werror=/s:yes:no:g' \
+               -i configure.ac || die
+       default
+       eautoreconf
+}
+
+src_configure() {
+       local myeconfargs=(
+               --enable-shared
+               $(use_enable static-libs static)
+               $(use_with sodium libsodium)
+               $(use_with pgm)
+       )
+       econf "${myeconfargs[@]}"
+}
+
+src_test() {
+       # Restricting to one job because multiple tests are using the same port.
+       # Upstream knows the problem and says it doesn't support parallel test
+       # execution, see ${S}/INSTALL.
+       emake -j1 check
+}
+
+src_install() {
+       default
+       find "${ED}"usr/lib* -name '*.la' -o -name '*.a' -delete || die
+}