net-dns/bind-tools: Version bump (v9.16.0)
authorMikle Kolyada <zlogene@gentoo.org>
Sun, 23 Feb 2020 12:51:19 +0000 (15:51 +0300)
committerMikle Kolyada <zlogene@gentoo.org>
Sun, 23 Feb 2020 12:51:19 +0000 (15:51 +0300)
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
net-dns/bind-tools/Manifest
net-dns/bind-tools/bind-tools-9.16.0.ebuild [new file with mode: 0644]

index 1da5c7da271a68886b2af598829239a3af5a57a8..c23881c54d9f117f17b61c00e4ce78a62275ee43 100644 (file)
@@ -1,2 +1,3 @@
 DIST bind-9.14.8.tar.gz 6403140 BLAKE2B 45cb06ce8564880d501c63d25c7af8567184e4e4293e01886620cf655449c972ab55c77c7aded07838c61557bc56d9edac26097715c1121fcfb6b606d7a29365 SHA512 eb52760982ebd246e6e1945684771193fc7364324a6d6a95a0cae33afa0a4fa24ffe8313b5f9094420c7c2ec932b1b1a9fb19f6e673ff3c5583ab5e3ff04eb6a
 DIST bind-9.14.9.tar.gz 6296339 BLAKE2B 65496ab94a83ddd1c519df4519373aa77858c6d66efed9342e962cd61943b12e9ecb2f74132015b3f835d0368d1cc59be23e0db92d4780f9f367c0d0fe8c3ada SHA512 aa6b1273f06fc16c842b7012a4d09cb65325a44ee88fea8bea8264ffa907ef4a6f8d5e09384599b2d6f5cea66c0dc220765c245814f54b2f09a5b6e65f97964b
+DIST bind-9.16.0.tar.xz 4533976 BLAKE2B f9892258a10a2423b4b26ae78927109c03ca39440f1d93d5d29369b666ef2ad8a8be72079f78a8b464f1e897b4d6c6511de280bba3f4e98fdf9604e9d1366c78 SHA512 6f836fe4cb12d3e2e3a871f69e5b249b2bae6ae1dc542395c79cc974ca95aa595e963b6716a38f6c9d5cb3c54ec606fcd932412a6fbe596651123ac1379dd010
diff --git a/net-dns/bind-tools/bind-tools-9.16.0.ebuild b/net-dns/bind-tools/bind-tools-9.16.0.ebuild
new file mode 100644 (file)
index 0000000..b87d93a
--- /dev/null
@@ -0,0 +1,137 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools flag-o-matic toolchain-funcs
+
+MY_PN=${PN//-tools}
+MY_PV=${PV/_p/-P}
+MY_PV=${MY_PV/_rc/rc}
+MY_P="${MY_PN}-${MY_PV}"
+
+DESCRIPTION="bind tools: dig, nslookup, host, nsupdate, dnssec-keygen"
+HOMEPAGE="https://www.isc.org/software/bind"
+SRC_URI="https://downloads.isc.org/isc/bind9/${PV}/${MY_P}.tar.xz"
+
+LICENSE="Apache-2.0 BSD BSD-2 GPL-2 HPND ISC MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="+caps doc gssapi idn ipv6 libedit libressl readline xml"
+# no PKCS11 currently as it requires OpenSSL to be patched, also see bug 409687
+
+COMMON_DEPEND="
+       caps? ( sys-libs/libcap )
+       !libressl? ( dev-libs/openssl:= )
+       libressl? ( dev-libs/libressl:= )
+       xml? ( dev-libs/libxml2 )
+       idn? ( net-dns/libidn2:= )
+       gssapi? ( virtual/krb5 )
+       libedit? ( dev-libs/libedit )
+       !libedit? (
+               readline? ( sys-libs/readline:= )
+       )"
+DEPEND="${COMMON_DEPEND}"
+
+RDEPEND="${COMMON_DEPEND}"
+
+BDEPEND="virtual/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+
+# bug 479092, requires networking
+RESTRICT="test"
+
+src_prepare() {
+       default
+
+       export LDFLAGS="${LDFLAGS} -L${EPREFIX}/usr/$(get_libdir)"
+
+       # Disable tests for now, bug 406399
+       sed -i '/^SUBDIRS/s:tests::' bin/Makefile.in lib/Makefile.in || die
+
+       # bug #220361
+       rm aclocal.m4 || die
+       rm -rf libtool.m4/ || die
+
+       eautoreconf
+}
+
+src_configure() {
+       local myeconfargs=(
+               --localstatedir="${EPREFIX}"/var
+               --without-python
+               --without-libjson
+               --without-zlib
+               --without-lmdb
+               --with-openssl="${EPREFIX}"/usr
+               $(use_with idn libidn2)
+               $(use_with xml libxml2)
+               $(use_with gssapi)
+               $(use_with readline)
+               $(use_enable caps linux-caps)
+       )
+
+       # bug 607400
+       if use libedit ; then
+               myeconfargs+=( --with-readline=-ledit )
+       elif use readline ; then
+               myeconfargs+=( --with-readline=-lreadline )
+       else
+               myeconfargs+=( --without-readline )
+       fi
+
+       # bug 344029
+       append-cflags "-DDIG_SIGCHASE"
+
+       # to expose CMSG_* macros from sys/sockets.h
+       [[ ${CHOST} == *-solaris* ]] && append-cflags "-D_XOPEN_SOURCE=600"
+
+       # localstatedir for nsupdate -l, bug 395785
+       tc-export BUILD_CC
+       econf "${myeconfargs[@]}"
+
+       # bug #151839
+       echo '#undef SO_BSDCOMPAT' >> config.h
+}
+
+src_compile() {
+       local AR=$(tc-getAR)
+
+       emake AR="${AR}" -C lib/
+       emake AR="${AR}" -C bin/delv/
+       emake AR="${AR}" -C bin/dig/
+       emake AR="${AR}" -C bin/nsupdate/
+       emake AR="${AR}" -C bin/dnssec/
+}
+
+src_install() {
+       dodoc README CHANGES
+
+       cd "${S}"/bin/delv || die
+       dobin delv
+       doman delv.1
+
+       cd "${S}"/bin/dig || die
+       dobin dig host nslookup
+       doman {dig,host,nslookup}.1
+
+       cd "${S}"/bin/nsupdate || die
+       dobin nsupdate
+       doman nsupdate.1
+       if use doc; then
+               docinto html
+               dodoc nsupdate.html
+       fi
+
+       cd "${S}"/bin/dnssec || die
+       for tool in dsfromkey importkey keyfromlabel keygen \
+               revoke settime signzone verify; do
+               dobin dnssec-"${tool}"
+               doman dnssec-"${tool}".8
+               if use doc; then
+                       docinto html
+                       dodoc dnssec-"${tool}".html
+               fi
+       done
+}