media-sound/flake: Port to EAPI 7
authorDavid Seifert <soap@gentoo.org>
Wed, 16 Oct 2019 11:39:42 +0000 (13:39 +0200)
committerDavid Seifert <soap@gentoo.org>
Wed, 16 Oct 2019 11:39:42 +0000 (13:39 +0200)
Bug: https://bugs.gentoo.org/697274
Package-Manager: Portage-2.3.77, Repoman-2.3.17
Signed-off-by: David Seifert <soap@gentoo.org>
media-sound/flake/flake-0.11.ebuild

index 5f1f3377e8d5a6dc7ac02be71f12eeb6d610be26..24f2e7b6ee1b62c07a35841214febf9965ea1a39 100644 (file)
@@ -1,7 +1,7 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=0
+EAPI=7
 
 inherit toolchain-funcs
 
@@ -12,22 +12,24 @@ SRC_URI="mirror://sourceforge/flake-enc/${P}.tar.bz2"
 LICENSE="LGPL-2.1"
 SLOT="0"
 KEYWORDS="amd64 x86"
-IUSE="debug"
 
-src_compile() {
-       local myconf
-
-       if ! use debug; then
-               myconf="${myconf} --disable-debug"
-       fi
-
-       ./configure --cc="$(tc-getCC)" --prefix="${D}"/usr \
-               --disable-opts --disable-strip ${myconf} || die "configure failed."
+src_configure() {
+       # NIH configure script
+       ./configure \
+               --cc="$(tc-getCC)" \
+               --prefix="${D}"/usr \
+               --disable-opts \
+               --disable-debug \
+               --disable-strip || die "configure failed"
+}
 
-       emake -j1 || die "emake failed."
+src_compile() {
+       emake -j1
 }
 
 src_install() {
-       emake install || die "emake install failed."
+       dobin flake/flake
+       doheader libflake/flake.h
+       dolib.a libflake/libflake.a
        dodoc Changelog README
 }