dev-cpp/gflags: EAPI=7
authorDavid Michael <dm0@redhat.com>
Tue, 12 Mar 2019 00:13:09 +0000 (20:13 -0400)
committerMichał Górny <mgorny@gentoo.org>
Sat, 6 Jul 2019 06:11:23 +0000 (08:11 +0200)
This allows the cmake eclass to use BDEPEND, so the host cmake can be
used without having to cross-compile it.

Signed-off-by: David Michael <dm0@redhat.com>
Package-Manager: Portage-2.3.51, Repoman-2.3.11
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-cpp/gflags/gflags-2.2.1-r1.ebuild [new file with mode: 0644]
dev-cpp/gflags/gflags-9999.ebuild

diff --git a/dev-cpp/gflags/gflags-2.2.1-r1.ebuild b/dev-cpp/gflags/gflags-2.2.1-r1.ebuild
new file mode 100644 (file)
index 0000000..95cd79c
--- /dev/null
@@ -0,0 +1,35 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-multilib
+
+if [[ ${PV} == 9999 ]]; then
+       inherit git-r3
+       EGIT_REPO_URI="https://github.com/gflags/gflags"
+else
+       SRC_URI="https://github.com/gflags/gflags/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+       KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+DESCRIPTION="Google's C++ argument parsing library"
+HOMEPAGE="http://gflags.github.io/gflags/"
+
+LICENSE="BSD"
+SLOT="0/2.2"
+IUSE="static-libs test"
+
+# AUTHORS.txt only links the google group
+DOCS=( ChangeLog.txt README.md )
+
+multilib_src_configure() {
+       local mycmakeargs=(
+               -DBUILD_STATIC_LIBS=$(usex static-libs)
+               -DBUILD_TESTING=$(usex test)
+               # avoid installing .cmake/packages, e.g.:
+               # >>> /tmp/portage/dev-cpp/gflags-9999/homedir/.cmake/packages/gflags/a7fca4708532331c2d656af0fdc8b8b9
+               -DREGISTER_INSTALL_PREFIX=OFF
+       )
+       cmake-utils_src_configure
+}
index 91f405e1e9bf846241931b0a67bfdfddf67b9fed..95cd79c7ef3d1a95901c58f5509de92a9e398af4 100644 (file)
@@ -1,7 +1,7 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI="6"
+EAPI=7
 
 inherit cmake-multilib
 
@@ -25,7 +25,6 @@ DOCS=( ChangeLog.txt README.md )
 
 multilib_src_configure() {
        local mycmakeargs=(
-               -DBUILD_SHARED_LIBS=ON
                -DBUILD_STATIC_LIBS=$(usex static-libs)
                -DBUILD_TESTING=$(usex test)
                # avoid installing .cmake/packages, e.g.: