app-backup/btrbk: initial commit for versions 0.23.3 and 9999
authorCraig Andrews <candrews@integralblue.com>
Tue, 12 Jul 2016 18:03:10 +0000 (14:03 -0400)
committerGöktürk Yüksek <gokturk@gentoo.org>
Thu, 14 Jul 2016 01:29:46 +0000 (21:29 -0400)
btrbk is a backup tool for btrfs subvolumes, taking advantage of btrfs
specific capabilities to create atomic snapshots and transfer them
incrementally to backup locations via ssh.

Gentoo-bug: 564780

app-backup/btrbk/Manifest [new file with mode: 0644]
app-backup/btrbk/btrbk-0.23.3.ebuild [new file with mode: 0644]
app-backup/btrbk/btrbk-9999.ebuild [new file with mode: 0644]
app-backup/btrbk/metadata.xml [new file with mode: 0644]

diff --git a/app-backup/btrbk/Manifest b/app-backup/btrbk/Manifest
new file mode 100644 (file)
index 0000000..44082d2
--- /dev/null
@@ -0,0 +1 @@
+DIST btrbk-0.23.3.tar.xz 69388 SHA256 779636116261e3e0fe64ec986e39be594c04454d87be8005115c8577f62b1725 SHA512 d9fc29b8e2a6e191be93c7845c7f1f99ab60fb4ec910d8b60947ef902b7fdaf789bc73a4884bdd6060f1b180cafaacd5fa8f93dc29624dfea8a2890618ce4012 WHIRLPOOL 4cc9aa102c46feccfb0b90e65d03dd53bed07d78e5a9ddd2afeccfe21fb29f9a2aeba8389771ee7c203598858fb94d59c0d19b73ce1fa29b3772e916bbf4f23b
diff --git a/app-backup/btrbk/btrbk-0.23.3.ebuild b/app-backup/btrbk/btrbk-0.23.3.ebuild
new file mode 100644 (file)
index 0000000..45cbbca
--- /dev/null
@@ -0,0 +1,33 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit systemd
+
+if [[ ${PV} == "9999" ]] ; then
+       EGIT_REPO_URI="git://dev.tty0.ch/btrbk.git"
+       inherit git-r3
+       SRC_URI=""
+       KEYWORDS=""
+else
+       SRC_URI="https://digint.ch/download/btrbk/releases/${P}.tar.xz"
+       KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Tool for creating snapshots and remote backups of btrfs subvolumes"
+HOMEPAGE="https://digint.ch/btrbk/"
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="+pv"
+
+DEPEND=""
+RDEPEND="dev-lang/perl
+       net-misc/openssh
+       pv? ( sys-apps/pv )
+       >=sys-fs/btrfs-progs-3.18.2"
+
+src_install() {
+       emake DESTDIR="${D}" DOCDIR="/usr/share/doc/${PF}" SYSTEMDDIR="$(systemd_get_systemunitdir)" install
+}
diff --git a/app-backup/btrbk/btrbk-9999.ebuild b/app-backup/btrbk/btrbk-9999.ebuild
new file mode 100644 (file)
index 0000000..45cbbca
--- /dev/null
@@ -0,0 +1,33 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit systemd
+
+if [[ ${PV} == "9999" ]] ; then
+       EGIT_REPO_URI="git://dev.tty0.ch/btrbk.git"
+       inherit git-r3
+       SRC_URI=""
+       KEYWORDS=""
+else
+       SRC_URI="https://digint.ch/download/btrbk/releases/${P}.tar.xz"
+       KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Tool for creating snapshots and remote backups of btrfs subvolumes"
+HOMEPAGE="https://digint.ch/btrbk/"
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="+pv"
+
+DEPEND=""
+RDEPEND="dev-lang/perl
+       net-misc/openssh
+       pv? ( sys-apps/pv )
+       >=sys-fs/btrfs-progs-3.18.2"
+
+src_install() {
+       emake DESTDIR="${D}" DOCDIR="/usr/share/doc/${PF}" SYSTEMDDIR="$(systemd_get_systemunitdir)" install
+}
diff --git a/app-backup/btrbk/metadata.xml b/app-backup/btrbk/metadata.xml
new file mode 100644 (file)
index 0000000..6694799
--- /dev/null
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+    <maintainer type="person">
+        <email>candrews@integralblue.com</email>
+        <name>Craig Andrews</name>
+    </maintainer>
+    <maintainer type="person">
+        <email>axel@tty0.ch</email>
+        <name>Axel Burri</name>
+    </maintainer>
+    <maintainer type="project">
+        <email>proxy-maint@gentoo.org</email>
+        <name>Proxy Maintainers</name>
+    </maintainer>
+    <longdescription lang="en">
+        Tool for creating snapshots and remote backups of btrfs subvolumes
+    </longdescription>
+    <use>
+        <flag name='pv'>Use sys-apps/pv to enable progress bar functionality</flag>
+    </use>
+</pkgmetadata>