net-wireless/yatebts: replace gdb specific debug flags with -g due to bug #606598
authorZero_Chaos <zerochaos@gentoo.org>
Fri, 20 Jan 2017 16:32:42 +0000 (11:32 -0500)
committerZero_Chaos <zerochaos@gentoo.org>
Fri, 20 Jan 2017 16:33:11 +0000 (11:33 -0500)
Package-Manager: Portage-2.3.3, Repoman-2.3.1

net-wireless/yatebts/yatebts-5.0.0.ebuild

index 7e0a85027fd59313fcf302fa8028ac26d13ca4b3..65d4ed19f521794f5fe344b4e9651bf175369ec7 100644 (file)
@@ -1,10 +1,10 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
 EAPI=5
 
-inherit eutils autotools
+inherit eutils autotools flag-o-matic
 
 DESCRIPTION="The Yate GSM base station"
 HOMEPAGE="http://www.yatebts.com/"
@@ -32,6 +32,10 @@ else
 fi
 
 src_prepare() {
+       replace-flags -ggdb -g
+       replace-flags -ggdb3 -g
+       replace-flags -ggdb2 -g
+       replace-flags -ggdb1 -g
        #epatch "${FILESDIR}"/${PN}-4.0.0-dont-mess-with-cflags.patch
        epatch "${FILESDIR}"/${PN}-sgsnggsn-inetutils-hostname-fix.diff
        eautoreconf