dev-python/setuptools: Revered unbundling of dev-python/packaging
authorJustin Lecher <jlec@gentoo.org>
Tue, 25 Aug 2015 08:15:06 +0000 (10:15 +0200)
committerJustin Lecher <jlec@gentoo.org>
Tue, 25 Aug 2015 08:15:57 +0000 (10:15 +0200)
setuptools without packaging requires packaging which requires setuptools
No way around this circular dependency as it is buildtime

Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=534026

Package-Manager: portage-2.2.20.1
Signed-off-by: Justin Lecher <jlec@gentoo.org>
dev-python/setuptools/setuptools-18.2-r2.ebuild [moved from dev-python/setuptools/setuptools-18.2-r1.ebuild with 75% similarity]

similarity index 75%
rename from dev-python/setuptools/setuptools-18.2-r1.ebuild
rename to dev-python/setuptools/setuptools-18.2-r2.ebuild
index 6de3213a1adb7742cba2c9f36f05be508df1925c..e75cef0c66c1fb2f123668cb3d5424ae2398e6c3 100644 (file)
@@ -14,11 +14,10 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
 
 LICENSE="PSF-2"
 SLOT="0"
-KEYWORDS="~amd64 ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
 IUSE="test"
 
-RDEPEND=">=dev-python/packaging-15.3[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
+DEPEND="
        test? (
                dev-python/pytest[${PYTHON_USEDEP}]
                dev-python/mock[${PYTHON_USEDEP}]
@@ -31,7 +30,6 @@ DISTUTILS_IN_SOURCE_BUILD=1
 DOCS=( README.txt docs/{easy_install.txt,pkg_resources.txt,setuptools.txt} )
 
 python_prepare_all() {
-       rm -r ./pkg_resources/_vendor || die
        # disable tests requiring a network connection
        rm setuptools/tests/test_packageindex.py || die