app-crypt/md6sum: Set CFLAGS+=-fcommon
authorJeroen Roovers <jer@gentoo.org>
Wed, 22 Apr 2020 08:24:27 +0000 (10:24 +0200)
committerJeroen Roovers <jer@gentoo.org>
Wed, 22 Apr 2020 08:29:44 +0000 (10:29 +0200)
This code is particularly evil in that it expressly omits a declaration
of the compression_hook function and apparently fully intended to rely
on the -fcommon mechanism to toggle debugging functions. See md6.h for
the rationale.

Package-Manager: Portage-2.3.99, Repoman-2.3.22
Closes: https://bugs.gentoo.org/706780
Signed-off-by: Jeroen Roovers <jer@gentoo.org>
app-crypt/md6sum/md6sum-1.0-r2.ebuild

index 631b65b9a6e852041afd30410c5ab980d14b88d9..5859b5ca9af3688a1c51cc1297f149031dc80fb0 100644 (file)
@@ -1,7 +1,8 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
+inherit flag-o-matic
 
 DESCRIPTION="A C implementation of MD6"
 HOMEPAGE="https://groups.csail.mit.edu/cis/md6"
@@ -16,3 +17,8 @@ PATCHES=(
        "${FILESDIR}/${P}-cflags.patch"
        "${FILESDIR}/${P}-format-security.patch"
 )
+
+src_configure() {
+       append-cflags -fcommon # bug #706780
+       default
+}