app-misc/ca-certificates: Bump to version 20161130.3.29
authorLars Wendler <polynomial-c@gentoo.org>
Tue, 14 Feb 2017 10:34:29 +0000 (11:34 +0100)
committerLars Wendler <polynomial-c@gentoo.org>
Tue, 14 Feb 2017 10:35:20 +0000 (11:35 +0100)
Package-Manager: Portage-2.3.3, Repoman-2.3.1

app-misc/ca-certificates/Manifest
app-misc/ca-certificates/ca-certificates-20161130.3.29.ebuild [new file with mode: 0644]

index 7e8ee9e74fcd1c2677778dc223da01e334e5b163..22a43bbcf1c7962f69073a9671bf2d5a2fb603f8 100644 (file)
@@ -6,4 +6,5 @@ DIST nss-3.21.tar.gz 6978112 SHA256 3f7a5b027d7cdd5c0e4ff7544da33fdc6f56c2f8c27f
 DIST nss-3.27.2.tar.gz 7397599 SHA256 dc8ac8524469d0230274fd13a53fdcd74efe4aa67205dde1a4a92be87dc28524 SHA512 699847665e93fd649cb60ce6bc8f849f452779e7232a09bbeb0613f9e6c57bb81948f1ae59cc86648e41a212cda259109850ccd14546d35910deb75f5d2a13b8 WHIRLPOOL 08229d87de1c7020c1d7fc12fb8a2afc4bc9ab9f0208aad12698aba17386fbe9163cb506101c7d4d568409fd99141fb88c0e71fc32cecbc6640a4a8f7a4efabf
 DIST nss-3.28.1.tar.gz 7451477 SHA256 58cc0c05c0ed9523e6d820bea74f513538f48c87aac931876e3d3775de1a82ad SHA512 f10c8e404741fafe5e5772dc754ff4503ec1826942db5fbc13b99155fcac50f29e1405dd249b69a27f27ebcfef73849b1f0f636a2076ab761384e8a0ed9a2b8b WHIRLPOOL e1a6b9886759159294c4d8e47e693a2e790703e368ede18425c9a9130df72ac56a6e717cb794607c7bcfc68c82df9aec8771bc74e729f5bbd70fdcd8ce0fed3b
 DIST nss-3.28.tar.gz 7440502 SHA256 c79dd15f66f581c294ce0ef032119357d03fee3a0aa61be263747d84f1b33254 SHA512 dd442c6d04edd0507cc49a1e3c2bfaa64555f7cde5cb9e512ccf33f14de458dddbb17efddd83271056ed6e6e32327e6e1b6f6609e1910a05e625b08e6f0965df WHIRLPOOL d013972f18d75e83da03c3903b712ef1094e6b8543c1755ea2b7ed7f6335e39ac20112808c86bb9df74cda4a8c5c1159401ecd05d1d8b07b3ecdca85f7f0ac82
+DIST nss-3.29.tar.gz 7477439 SHA256 ee19ebfe7b012dedb71f04a55dd06fa26f8dce435e5980531c790bd42673c6fa SHA512 0f4dd026b6b32122d8cafa92fa37199b0678f8fef75e375446eddd0cc6ddda1a796e3222caa8bb01b3633911899394d0cb1e4d392880438f68c8ef7290dcb4fa WHIRLPOOL 5d3243bcc5c78e1b13b463e935bb5f700d0ed32eb22b01ccda17cb475725230f73f3711227a2175add4e96e0353aaf484ff10b0186cf4a453dfa215c24b8147c
 DIST nss-cacert-class1-class3.patch 22950 SHA256 6bba29cee34276e2ca6436dabedfeba2b61fb46668c5d5ceabf0c871574649bf SHA512 a5aa740bf110a3f0262e3f1ef2fc739ac2b44f042e220039d48aee8e97cd764d5c10718220364f4098aba955882bd02cadb5481512388971a8290312f88a7df0 WHIRLPOOL 1246223b01292604e5609bb9c580f092dc5937bf8c98f6891b099e8bab960e03612b6617e30a55d6ff8817d88f190e03812fe8f89f84f25c20970493dc2f7700
diff --git a/app-misc/ca-certificates/ca-certificates-20161130.3.29.ebuild b/app-misc/ca-certificates/ca-certificates-20161130.3.29.ebuild
new file mode 100644 (file)
index 0000000..91c4bc6
--- /dev/null
@@ -0,0 +1,183 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+# The Debian ca-certificates package merely takes the CA database as it exists
+# in the nss package and repackages it for use by openssl.
+#
+# The issue with using the compiled debs directly is two fold:
+# - they do not update frequently enough for us to rely on them
+# - they pull the CA database from nss tip of tree rather than the release
+#
+# So we take the Debian source tools and combine them with the latest nss
+# release to produce (largely) the same end result.  The difference is that
+# now we know our cert database is kept in sync with nss and, if need be,
+# can be sync with nss tip of tree more frequently to respond to bugs.
+
+# When triaging bugs from users, here's some handy tips:
+# - To see what cert is hitting errors, use openssl:
+#   openssl s_client -port 443 -CApath /etc/ssl/certs/ -host $HOSTNAME
+#   Focus on the errors written to stderr.
+#
+# - Look at the upstream log as to why certs were added/removed:
+#   https://hg.mozilla.org/projects/nss/log/tip/lib/ckfw/builtins/certdata.txt
+#
+# - If people want to add/remove certs, tell them to file w/mozilla:
+#   https://bugzilla.mozilla.org/enter_bug.cgi?product=NSS&component=CA%20Certificates&version=trunk
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit eutils python-any-r1
+
+if [[ ${PV} == *.* ]] ; then
+       # Compile from source ourselves.
+       PRECOMPILED=false
+       inherit versionator
+
+       DEB_VER=$(get_version_component_range 1)
+       NSS_VER=$(get_version_component_range 2-)
+       RTM_NAME="NSS_${NSS_VER//./_}_RTM"
+else
+       # Debian precompiled version.
+       PRECOMPILED=true
+       inherit unpacker
+fi
+
+DESCRIPTION="Common CA Certificates PEM files"
+HOMEPAGE="http://packages.debian.org/sid/ca-certificates"
+NMU_PR=""
+if ${PRECOMPILED} ; then
+       SRC_URI="mirror://debian/pool/main/c/${PN}/${PN}_${PV}${NMU_PR:++nmu}${NMU_PR}_all.deb"
+else
+       SRC_URI="mirror://debian/pool/main/c/${PN}/${PN}_${DEB_VER}${NMU_PR:++nmu}${NMU_PR}.tar.xz
+               https://archive.mozilla.org/pub/security/nss/releases/${RTM_NAME}/src/nss-${NSS_VER}.tar.gz
+               cacert? (
+                       https://dev.gentoo.org/~axs/distfiles/nss-cacert-class1-class3.patch
+               )"
+fi
+
+LICENSE="MPL-1.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
+IUSE="insecure_certs"
+${PRECOMPILED} || IUSE+=" cacert"
+
+DEPEND=""
+if ${PRECOMPILED} ; then
+       DEPEND+=" !<sys-apps/portage-2.1.10.41"
+fi
+# c_rehash: we run `c_rehash`
+# debianutils: we run `run-parts`
+RDEPEND="${DEPEND}
+       app-misc/c_rehash
+       sys-apps/debianutils"
+
+if ! ${PRECOMPILED}; then
+       DEPEND+=" ${PYTHON_DEPS}"
+fi
+
+S=${WORKDIR}
+
+pkg_setup() {
+       # For the conversion to having it in CONFIG_PROTECT_MASK,
+       # we need to tell users about it once manually first.
+       [[ -f "${EPREFIX}"/etc/env.d/98ca-certificates ]] \
+               || ewarn "You should run update-ca-certificates manually after etc-update"
+}
+
+src_unpack() {
+       ${PRECOMPILED} || default
+
+       # Do all the work in the image subdir to avoid conflicting with source
+       # dirs in $WORKDIR.  Need to perform everything in the offset #381937
+       mkdir -p "image/${EPREFIX}"
+       cd "image/${EPREFIX}" || die
+
+       ${PRECOMPILED} && unpacker_src_unpack
+}
+
+src_prepare() {
+       cd "image/${EPREFIX}" || die
+       if ! ${PRECOMPILED} ; then
+               mkdir -p usr/sbin
+               cp -p "${S}"/${PN}/sbin/update-ca-certificates usr/sbin/ || die
+
+               if use cacert ; then
+                       pushd "${S}"/nss-${NSS_VER} >/dev/null
+                       epatch "${DISTDIR}"/nss-cacert-class1-class3.patch
+                       popd >/dev/null
+               fi
+       fi
+
+       epatch "${FILESDIR}"/${PN}-20150426-root.patch
+       local relp=$(echo "${EPREFIX}" | sed -e 's:[^/]\+:..:g')
+       sed -i \
+               -e '/="$ROOT/s:ROOT:ROOT'"${EPREFIX}"':' \
+               -e '/RELPATH="\.\./s:"$:'"${relp}"'":' \
+               usr/sbin/update-ca-certificates || die
+}
+
+src_compile() {
+       cd "image/${EPREFIX}" || die
+       if ! ${PRECOMPILED} ; then
+               python_setup
+               local d="${S}/${PN}/mozilla" c="usr/share/${PN}"
+               # Grab the database from the nss sources.
+               cp "${S}"/nss-${NSS_VER}/nss/lib/ckfw/builtins/{certdata.txt,nssckbi.h} "${d}" || die
+               emake -C "${d}"
+
+               # Now move the files to the same places that the precompiled would.
+               mkdir -p etc/ssl/certs etc/ca-certificates/update.d "${c}"/mozilla
+               if use cacert ; then
+                       mkdir -p "${c}"/cacert.org
+                       mv "${d}"/CAcert_Inc..crt "${c}"/cacert.org/cacert.org_root.crt || die
+               fi
+               mv "${d}"/*.crt "${c}"/mozilla/ || die
+       else
+               mv usr/share/doc/{ca-certificates,${PF}} || die
+       fi
+
+       if ! use insecure_certs ; then
+               # Remove untrusted certs from StartCom and WoSign (bug #598072)
+               rm "${c}"/mozilla/StartCom* || die
+               rm "${c}"/mozilla/WoSign* || die
+       fi
+
+       (
+       echo "# Automatically generated by ${CATEGORY}/${PF}"
+       echo "# $(date -u)"
+       echo "# Do not edit."
+       cd "${c}"
+       find * -name '*.crt' | LC_ALL=C sort
+       ) > etc/ca-certificates.conf
+
+       sh usr/sbin/update-ca-certificates --root "${S}/image" || die
+}
+
+src_install() {
+       cp -pPR image/* "${D}"/ || die
+       if ! ${PRECOMPILED} ; then
+               cd ca-certificates
+               doman sbin/*.8
+               dodoc debian/README.* examples/ca-certificates-local/README
+       fi
+
+       echo 'CONFIG_PROTECT_MASK="/etc/ca-certificates.conf"' > 98ca-certificates
+       doenvd 98ca-certificates
+}
+
+pkg_postinst() {
+       if [ -d "${EROOT}/usr/local/share/ca-certificates" ] ; then
+               # if the user has local certs, we need to rebuild again
+               # to include their stuff in the db.
+               # However it's too overzealous when the user has custom certs in place.
+               # --fresh is to clean up dangling symlinks
+               "${EROOT}"/usr/sbin/update-ca-certificates --root "${ROOT}"
+       fi
+
+       if [ -n "$(find -L "${EROOT}"etc/ssl/certs/ -type l)" ] ; then
+               ewarn "Removing the following broken symlinks:"
+               ewarn "$(find -L "${EROOT}"/etc/ssl/certs/ -type l -printf '%p -> %l\n' -delete)"
+       fi
+}