dev-ml/ocaml-ctypes: bump to 0.7.0
authorAlexis Ballier <aballier@gentoo.org>
Mon, 18 Jul 2016 13:17:57 +0000 (15:17 +0200)
committerAlexis Ballier <aballier@gentoo.org>
Mon, 18 Jul 2016 13:20:44 +0000 (15:20 +0200)
Package-Manager: portage-2.3.0

dev-ml/ocaml-ctypes/Manifest
dev-ml/ocaml-ctypes/ocaml-ctypes-0.7.0.ebuild [new file with mode: 0644]

index b9a2496597fdf04878d3be7ae383f31646ef996b..e413248d08d128d673da2f9aff4c908f48d9627d 100644 (file)
@@ -1,2 +1,3 @@
 DIST ocaml-ctypes-0.4.1.tar.gz 162601 SHA256 74564e049de5d3c0e76ea284c225cb658ac1a2b483345be1efb9be4b3c1702f5 SHA512 8155ffe16a58d5714ceb602afa5531c93526defca39a16047328ac06d2c7c7f52b768b18170391f467e1f6919c69275734faf85d27315e11b8bbefcb1bc8afa9 WHIRLPOOL d8d0ef24e0b6c40f50fddf38fed7238cf95573909d2809cc2ab5c1b9b3dab333210e1ce99cf805804576a79d08d819e2ecdee7b4a6a9e13efb13e7b9f88ad802
 DIST ocaml-ctypes-0.6.2.tar.gz 179953 SHA256 f31671c6515b9f9df245ec08e8ac6842cf33b7d9b76799cc07f8b77b093de55f SHA512 65b975f51daa29f59c07eec558eb5f688452a8e30edeeeca186d60f4cb56e087c5943b6f59d7dfa5f69ae9cace22ecc135148f99754693af684fd75178dafa24 WHIRLPOOL ad016187e9ce0657d38b8d98a986e9886e01b5f21f2090e89ba6d6dc91e16fce91c9d284b826f4dd1e46b9ffd9df3a4656f22e2023cece5994642a74547501c4
+DIST ocaml-ctypes-0.7.0.tar.gz 181164 SHA256 8a68597b8545b36d7ced83a3365767ad0ebae99382ca7c8fff2a97666a78f94c SHA512 78929d4d9dd47e08751231a649f74259973333ecae84e6152b0a3e16a78da6b8b95bd8f69842b3b052324ecf96457eaa2b894557888aa53271917f9135259353 WHIRLPOOL 4edab9bacbea2f01676f0adc8b7058acd6097808c9d53e6d47320341de127634a3c0db3cdfd54678fdc97cb1bae8400ae79f8c5f5d55a921a3555d4f7c4ddc3a
diff --git a/dev-ml/ocaml-ctypes/ocaml-ctypes-0.7.0.ebuild b/dev-ml/ocaml-ctypes/ocaml-ctypes-0.7.0.ebuild
new file mode 100644 (file)
index 0000000..d563719
--- /dev/null
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit findlib
+
+DESCRIPTION="Library for binding to C libraries using pure OCaml"
+HOMEPAGE="https://github.com/ocamllabs/ocaml-ctypes"
+SRC_URI="https://github.com/ocamllabs/ocaml-ctypes/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="test"
+
+RDEPEND="
+       >=dev-lang/ocaml-4.02:=[ocamlopt]
+       virtual/libffi
+"
+DEPEND="${RDEPEND}
+       test? ( dev-ml/ounit )"
+
+src_compile() {
+       emake -j1
+}
+
+src_test() {
+       emake -j1 test
+}
+
+src_install() {
+       findlib_src_install
+       dodoc CHANGES.md README.md
+}