dev-python/pytest-asyncio: Set DISTUTILS_USE_SETUPTOOLS
authorMichał Górny <mgorny@gentoo.org>
Mon, 20 Apr 2020 13:31:09 +0000 (15:31 +0200)
committerMichał Górny <mgorny@gentoo.org>
Mon, 20 Apr 2020 15:48:52 +0000 (17:48 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/pytest-asyncio/pytest-asyncio-0.10.0.ebuild

index e56c6cce8a45c6dc9261bb3a0c0e93b6f66931ad..f7b4cfba907bf8ffedad72e8123948cadc1243df 100644 (file)
@@ -3,7 +3,9 @@
 
 EAPI=7
 
+DISTUTILS_USE_SETUPTOOLS=rdepend
 PYTHON_COMPAT=( python3_{6,7,8} )
+
 inherit distutils-r1
 
 DESCRIPTION="Library for testing asyncio code with pytest"
@@ -18,9 +20,8 @@ IUSE="test"
 RESTRICT="!test? ( test )"
 
 RDEPEND="
-       dev-python/pytest[${PYTHON_USEDEP}]
-       dev-python/setuptools[${PYTHON_USEDEP}]"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+       dev-python/pytest[${PYTHON_USEDEP}]"
+DEPEND="
        test? (
                ${RDEPEND}
                dev-python/async_generator[${PYTHON_USEDEP}]