media-radio/wsjtx: Fix build with QT_VERSION >= 5.14
authorThomas Beierlein <tomjbe@gentoo.org>
Sun, 12 Apr 2020 15:35:17 +0000 (17:35 +0200)
committerThomas Beierlein <tomjbe@gentoo.org>
Sun, 12 Apr 2020 15:35:17 +0000 (17:35 +0200)
Package-Manager: Portage-2.3.98, Repoman-2.3.22
Signed-off-by: Thomas Beierlein <tomjbe@gentoo.org>
media-radio/wsjtx/files/wsjtx-2.1.2-qt_helpers.patch [new file with mode: 0644]
media-radio/wsjtx/wsjtx-2.1.2.ebuild

diff --git a/media-radio/wsjtx/files/wsjtx-2.1.2-qt_helpers.patch b/media-radio/wsjtx/files/wsjtx-2.1.2-qt_helpers.patch
new file mode 100644 (file)
index 0000000..553a3bc
--- /dev/null
@@ -0,0 +1,20 @@
+# build with newer qt-5.14
+# patch provided by  nrdufour at the wsjtx mailing list
+--- a/qt_helpers.hpp    2019-11-26 09:22:32.000000000 -0500
++++ b/qt_helpers.hpp    2020-02-03 11:30:07.488214336 -0500
+@@ -83,6 +83,7 @@
+   // std::hash<> specialization for QString based on the dbj2
+   // algorithm <http://www.cse.yorku.ca/~oz/hash.html> because qHash()
+   // is poor on 64-bit platforms due to being a 32-bit hash value
++  #if QT_VERSION < QT_VERSION_CHECK(5, 14, 0)
+   template<>
+   struct hash<QString>
+   {
+@@ -96,6 +97,7 @@
+       return hash;
+     }
+   };
++#endif
+ }
+
+ // Register some useful Qt types with QMetaType
index 15c7d5cf22d839b3b6e3929a966ea8221e5d2198..b1d82d5b375b3d079aa25e65fcb1cdb04c372801 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -39,7 +39,8 @@ S=${WORKDIR}/wsjtx
 
 PATCHES=( "${FILESDIR}/${PN}-2.0.1-hamlib.patch"
                  "${FILESDIR}/${PN}-fix-unicode.patch"
-                 "${FILESDIR}/${PN}-drop-docs.patch" )
+                 "${FILESDIR}/${PN}-drop-docs.patch"
+                 "${FILESDIR}/${PN}-2.1.2-qt_helpers.patch" )
 
 DOCS=( AUTHORS BUGS NEWS README THANKS )