dev-python/fasteners: 0.14.1-r1 adding py37
authorMatthew Thode <prometheanfire@gentoo.org>
Tue, 9 Apr 2019 03:48:47 +0000 (22:48 -0500)
committerMatthew Thode <prometheanfire@gentoo.org>
Tue, 9 Apr 2019 07:04:40 +0000 (02:04 -0500)
Package-Manager: Portage-2.3.62, Repoman-2.3.12
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
dev-python/fasteners/fasteners-0.14.1-r1.ebuild [new file with mode: 0644]

diff --git a/dev-python/fasteners/fasteners-0.14.1-r1.ebuild b/dev-python/fasteners/fasteners-0.14.1-r1.ebuild
new file mode 100644 (file)
index 0000000..82e5591
--- /dev/null
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7,7} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Python package that provides useful locks"
+HOMEPAGE="https://github.com/harlowja/fasteners"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+       >=dev-python/monotonic-0.1[${PYTHON_USEDEP}]
+       dev-python/six[${PYTHON_USEDEP}]"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+       test? (
+               ${RDEPEND}
+               dev-python/nose[${PYTHON_USEDEP}]
+               dev-python/testtools[${PYTHON_USEDEP}]
+               virtual/python-futures[${PYTHON_USEDEP}] )"
+
+python_test() {
+       nosetests -v || die
+}