net-voip/telepathy-salut: fix python_check_deps, bug #628486
authorGilles Dartiguelongue <eva@gentoo.org>
Thu, 24 Aug 2017 22:04:29 +0000 (00:04 +0200)
committerGilles Dartiguelongue <eva@gentoo.org>
Thu, 24 Aug 2017 22:47:41 +0000 (00:47 +0200)
Package-Manager: Portage-2.3.8, Repoman-2.3.3

net-voip/telepathy-salut/telepathy-salut-0.8.1-r1.ebuild

index f5766fe7ad3570a537e2fc0aa92d0711c7eb0b08..10baef9097d101faf6e1c1aa179dff5c98592619 100644 (file)
@@ -50,9 +50,10 @@ PATCHES=(
 )
 
 python_check_deps() {
-       use test \
-               && { has_version "dev-python/twisted[${PYTHON_USEDEP}]" \
-                       || has_version "dev-python/twisted-words[${PYTHON_USEDEP}]"; }
+       if use test ; then
+                has_version "dev-python/twisted[${PYTHON_USEDEP}]" \
+                       || has_version "dev-python/twisted-words[${PYTHON_USEDEP}]"
+       fi
 }
 
 pkg_setup() {