dev-python/github3: bump to support newer GitHub API auth requirements
authorRobin H. Johnson <robbat2@gentoo.org>
Sun, 5 Apr 2020 23:58:53 +0000 (16:58 -0700)
committerRobin H. Johnson <robbat2@gentoo.org>
Mon, 6 Apr 2020 00:02:43 +0000 (17:02 -0700)
Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
dev-python/github3/Manifest
dev-python/github3/github3-1.3.0.ebuild [new file with mode: 0644]

index c69b50a2cfc2dba6cf177f452bc8b7b44f8af9d7..074316c46f9c6a442aa3545e8ab2ebb861c25908 100644 (file)
@@ -1 +1,2 @@
 DIST github3-0.9.3.tar.gz 783446 BLAKE2B 976013511e30a4e373ec4f986fd615e27d866ed38a4cf08d53f24be527b5c8ced38cc63f49eef7b6418d9ab5df3ff7d631e0abaabf10c20472eb9a14c212d3a4 SHA512 23d7ca5d9e5c4efd37541ec0be56bcc50c36d141999196ea2f0c17068ef1235e758d48c3e4fe9c8e204bac98931995913a4c3af227cfdbb7382bec8ac91b3c19
+DIST github3-1.3.0.tar.gz 35345711 BLAKE2B 37d5b574c228b9e3c7ddd60931140679dcfa2a410964d25cfa51d621a0bc72cf4c5340ae3565c0112a3f5373aa064bdc4663dc2d3c4fdf3d0008239bd3498362 SHA512 0568d9730764fb81975da2ba336f1cdb2196de687fe6e68cb3dc2ac432bbcb201f1d78647ac2606a105ea00e6b244cb79b7222f88ebf305a9b7783c2b21e5a1b
diff --git a/dev-python/github3/github3-1.3.0.ebuild b/dev-python/github3/github3-1.3.0.ebuild
new file mode 100644 (file)
index 0000000..7f4dc2c
--- /dev/null
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="A wrapper for the GitHub API written in python"
+HOMEPAGE="https://github3py.readthedocs.io/en/master/"
+SRC_URI="https://github.com/sigmavirus24/${PN}.py/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+       dev-vcs/git
+       >=dev-python/requests-2.18.0[${PYTHON_USEDEP}]
+       >=dev-python/uritemplate-3.0.0[${PYTHON_USEDEP}]
+       >=dev-python/python-dateutil-2.6.0[${PYTHON_USEDEP}]
+       >=dev-python/jwcrypto-0.5.0[${PYTHON_USEDEP}]
+       ${PYTHON_DEPS}"
+DEPEND="${RDEPEND}
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       test? (
+               >dev-python/pytest-2.3.5[${PYTHON_USEDEP}]
+               >=dev-python/betamax-0.8.0[${PYTHON_USEDEP}]
+               >=dev-python/betamax-matchers-0.1.0[${PYTHON_USEDEP}]
+       )"
+
+S="${WORKDIR}/${PN}.py-${PV}"
+
+distutils_enable_tests pytest