dev-python/sphinx-prompt: Sphinx directive to add unselectable prompt
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>
Thu, 14 May 2020 12:30:19 +0000 (14:30 +0200)
committerMatt Turner <mattst88@gentoo.org>
Tue, 26 May 2020 20:41:47 +0000 (13:41 -0700)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net>
Signed-off-by: Matt Turner <mattst88@gentoo.org>
dev-python/sphinx-prompt/Manifest [new file with mode: 0644]
dev-python/sphinx-prompt/metadata.xml [new file with mode: 0644]
dev-python/sphinx-prompt/sphinx-prompt-1.2.0.ebuild [new file with mode: 0644]

diff --git a/dev-python/sphinx-prompt/Manifest b/dev-python/sphinx-prompt/Manifest
new file mode 100644 (file)
index 0000000..30c5fbc
--- /dev/null
@@ -0,0 +1 @@
+DIST sphinx-prompt-1.2.0.tar.gz 7506 BLAKE2B babff99a29b87ba9529d7811a5b34280b1d30a4f7dbde8cea28a3c2ec687d1d4443b6bd8b0fb3ab5bdd002066ef1d3117768a529e46691fbec9de59d5c8771a8 SHA512 e3fe2740bee8a0107a12e131d3a4f90ed22c4bcceab7cb94fc869a534725552d4d3a9d8519a54782c5a1913a2e3bee088fa14db7b3a37f256be3243c7f6a9a1f
diff --git a/dev-python/sphinx-prompt/metadata.xml b/dev-python/sphinx-prompt/metadata.xml
new file mode 100644 (file)
index 0000000..5442995
--- /dev/null
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+  <maintainer type="project">
+    <email>python@gentoo.org</email>
+    <name>Python</name>
+  </maintainer>
+  <upstream>
+    <remote-id type="pypi">sphinx-prompt</remote-id>
+    <remote-id type="github">sbrunner/sphinx-prompt</remote-id>
+  </upstream>
+</pkgmetadata>
diff --git a/dev-python/sphinx-prompt/sphinx-prompt-1.2.0.ebuild b/dev-python/sphinx-prompt/sphinx-prompt-1.2.0.ebuild
new file mode 100644 (file)
index 0000000..6dab60f
--- /dev/null
@@ -0,0 +1,21 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Sphinx directive to add unselectable prompt"
+HOMEPAGE="https://github.com/sbrunner/sphinx-prompt/"
+SRC_URI="https://github.com/sbrunner/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+       dev-python/sphinx[${PYTHON_USEDEP}]
+       dev-python/pygments[${PYTHON_USEDEP}]
+"