net-irc/unrealircd: version bump 5.0.3.1
authorMichael Palimaka <kensington@gentoo.org>
Sun, 1 Mar 2020 02:09:04 +0000 (13:09 +1100)
committerMichael Palimaka <kensington@gentoo.org>
Sun, 1 Mar 2020 02:09:39 +0000 (13:09 +1100)
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Michael Palimaka <kensington@gentoo.org>
net-irc/unrealircd/Manifest
net-irc/unrealircd/unrealircd-5.0.3.1.ebuild [new file with mode: 0644]

index 58f56e803afec94ba52cd553153acb96c7bf256d..7dd56d86c12f4d5fec756a776fb836b253a05214 100644 (file)
@@ -1,3 +1,4 @@
 DIST unrealircd-4.2.4.1.tar.gz 6090725 BLAKE2B 817a7c2a13a495944676d08ed90b36f6795fe43ee171efc6661980e6da9a8cc8d98c4fb0eb8221ac6af85ab1a9b5578a2e992d7b41696434430e58918bc30145 SHA512 752573c4af1f92a10739bb2b0cdaade1948207b46d28ae5177e1dfd6b0663044bc22dce5ffe8549882cd70325e3ef7e3296182fffbb84e08d59dbbdd6551a686
 DIST unrealircd-5.0.1.tar.gz 4892906 BLAKE2B bf3515dc962ead462b32dd3a2dd44b292306ea4c64f1405c54e89d835565506394b5dab9d244a9df316afc150808baddcb53c500ef026db50c570024295cc4e1 SHA512 5ca8a05f985d07ad9e676c39a8ba5e1409797a155a9df505f685ab4d6616af30ad3946b933df75bdea66ab3984578af77144f67bea7fd65b16ba6da250c09eed
+DIST unrealircd-5.0.3.1.tar.gz 4902967 BLAKE2B d3c2e2399091b3aa9906583231d5ba42534234c4c40ce7412609fe8866438848bb69a4fc3cd378e0ed9ab13970ba2a7b27ba9fccdaaaea3585ec0a05aa5f89c2 SHA512 1bf3e2aab2f14d68a02ae6925d9e91135a92cf08886f703be0cd203c8b4b323bfc3930254d2bda381e60b3991f379115c954fa1fd262e28d7a27172a25bb172a
 DIST unrealircd-5.0.3.tar.gz 4902148 BLAKE2B 954ee5a6953378809b0bfe793a698c3dd0f243af0dea651391fa953a13f4ea8b71925bfeecbf9cff4098d51bb6cb154559d6ea8608bfb0e98790c137bb4ac20b SHA512 7fdee09cecebc1c2ceb9456c1d49bef566f240ca03827aa35a16c875f7aa8e1fc1e520a5f922303de56bfe828e4fdb6bf9fc6513b4defe24f3b77678603f7a56
diff --git a/net-irc/unrealircd/unrealircd-5.0.3.1.ebuild b/net-irc/unrealircd/unrealircd-5.0.3.1.ebuild
new file mode 100644 (file)
index 0000000..10fd8b7
--- /dev/null
@@ -0,0 +1,168 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+SSL_CERT_MANDATORY=1
+inherit ssl-cert
+
+DESCRIPTION="An advanced Internet Relay Chat daemon"
+HOMEPAGE="https://www.unrealircd.org/"
+SRC_URI="https://www.unrealircd.org/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux"
+IUSE="class-nofakelag curl libressl +operoverride operoverride-verify +prefixaq showlistmodes"
+
+RDEPEND="
+       acct-group/unrealircd
+       acct-user/unrealircd
+       >=app-crypt/argon2-20171227-r1:=
+       dev-libs/libpcre2
+       >=net-dns/c-ares-1.7:=
+       !libressl? ( dev-libs/openssl:0= )
+       libressl? ( dev-libs/libressl:= )
+       curl? ( net-misc/curl[adns] )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+DOCS=( doc/{Authors,Donation,RELEASE-NOTES.md,tao.of.irc,technical/,translations.txt} )
+
+src_prepare() {
+       # QA check against bundled pkgs
+       rm -r extras || die
+
+       # building third-party modules (which we don't do) cause a sandbox violation
+       # bug 704444
+       echo "" > src/buildmod || die
+
+       if use class-nofakelag; then
+               sed -i -e 's:#undef\( FAKELAG_CONFIGURABLE\):#define\1:' include/config.h || die
+       fi
+
+       eapply_user
+}
+
+src_configure() {
+       # Default value for privatelibdir adds a build path to -Wl,-rpath.
+       econf \
+               --with-bindir="${EPREFIX}"/usr/bin \
+               --with-cachedir="${EPREFIX}"/var/lib/${PN} \
+               --with-confdir="${EPREFIX}"/etc/${PN} \
+               --with-datadir="${EPREFIX}"/var/lib/${PN} \
+               --with-docdir="${EPREFIX}"/usr/share/doc/${PF} \
+               --with-logdir="${EPREFIX}"/var/log/${PN} \
+               --with-modulesdir="${EPREFIX}"/usr/"$(get_libdir)"/${PN}/modules \
+               --without-privatelibdir \
+               --with-pidfile="${EPREFIX}"/run/${PN}/ircd.pid \
+               --with-tmpdir="${EPREFIX}"/var/lib/${PN}/tmp \
+               --with-maxconnections=1024 \
+               --with-nick-history=2000 \
+               --with-permissions=0640 \
+               --with-system-argon2 \
+               --with-system-cares \
+               --with-system-pcre2 \
+               --enable-dynamic-linking \
+               --enable-ssl="${EPREFIX}"/usr \
+               $(use_enable curl libcurl "${EPREFIX}"/usr) \
+               $(use_enable prefixaq) \
+               $(use_with showlistmodes) \
+               $(use_with !operoverride no-operoverride) \
+               $(use_with operoverride-verify)
+}
+
+src_install() {
+       keepdir /var/log/${PN}
+       keepdir /var/lib/${PN}/tmp
+
+       newbin src/ircd ${PN}
+
+       (
+               cd src/modules || die
+               for subdir in $(find . -type d -print); do
+                       if [[ -n $(shopt -s nullglob; echo ${subdir}/*.so) ]]; then
+                               exeinto /usr/$(get_libdir)/${PN}/modules/"${subdir}"
+                               doexe "${subdir}"/*.so
+                       fi
+               done
+       )
+
+       insinto /etc/${PN}
+       # Purposefully omitting the examples/ and ssl/ subdirectories. ssl
+       # is redundant with app-misc/ca-certificates and examples will all
+       # be in docs anyway.
+       doins -r doc/conf/{aliases,help}
+       doins doc/conf/*.conf
+       newins doc/conf/examples/example.conf ${PN}.conf
+       keepdir /etc/${PN}/tls
+
+       einstalldocs
+
+       newinitd "${FILESDIR}"/${PN}.initd-r2 ${PN}
+       newconfd "${FILESDIR}"/${PN}.confd-r3 ${PN}
+
+       # config should be read-only
+       fperms -R 0640 /etc/${PN}
+       fperms 0750 /etc/${PN}{,/aliases,/help}
+       fperms 0750 /etc/${PN}/tls
+       # state is editable but not owned by unrealircd directly
+       fperms 0770 /var/log/${PN}
+       fperms 0770 /var/lib/${PN}{,/tmp}
+       fowners -R root:unrealircd /{etc,var/{lib,log}}/${PN}
+
+       # By default looks in /etc/unrealircd/ssl/curl-ca-bundle.crt. Fix
+       # that to look for ca-certificates-provided file instead. %s is
+       # CONFDIR. #618066
+       dosym ../../ssl/certs/ca-certificates.crt /etc/${PN}/tls/curl-ca-bundle.crt
+}
+
+pkg_postinst() {
+       # Move docert call from src_install() to install_cert in pkg_postinst for
+       # bug #201682
+       if [[ ! -f "${EROOT}"/etc/${PN}/tls/server.cert.key ]]; then
+               if [[ -f "${EROOT}"/etc/${PN}/ssl/server.cert.key ]]; then
+                       ewarn "The location ${PN} looks for SSL certificates has changed"
+                       ewarn "from ${EROOT}/etc/${PN}/ssl to ${EROOT}/etc/${PN}/tls."
+                       ewarn "Please move your existing certificates."
+               else
+                       (
+                               umask 0037
+                               install_cert /etc/${PN}/tls/server.cert
+                               chown unrealircd "${EROOT}"/etc/${PN}/tls/server.cert.*
+                               ln -snf server.cert.key "${EROOT}"/etc/${PN}/tls/server.key.pem
+                       )
+               fi
+       fi
+
+       local unrealircd_conf="${EROOT}"/etc/${PN}/${PN}.conf
+       # Fix up the default cloak keys.
+       if grep -qe '"and another one";$' "${unrealircd_conf}" && grep -qe '"aoAr1HnR6gl3sJ7hVz4Zb7x4YwpW";$' "${unrealircd_conf}"; then
+               ebegin "Generating cloak-keys"
+               local keys=(
+                       $(su ${PN} -s /bin/sh -c "${PN} -k 2>&1 | tail -n 3")
+               )
+               [[ -n ${keys[0]} || -n ${keys[1]} || -n ${keys[2]} ]]
+               eend $?
+
+               ebegin "Substituting cloak-keys into ${unrealircd_conf}"
+               sed -i \
+                       -e '/cloak-keys/ {
+n
+s/"aoAr1HnR6gl3sJ7hVz4Zb7x4YwpW";/"'"${keys[0]}"'";/
+n
+s/"and another one";/"'"${keys[1]}"'";/
+n
+s/"and another one";/"'"${keys[2]}"'";/
+}' \
+                       "${unrealircd_conf}"
+               eend $?
+       fi
+
+       elog "UnrealIRCd will not run until you've set up /etc/unrealircd/unrealircd.conf"
+       elog
+       elog "You can also configure ${PN} start at boot with rc-update(1)."
+       elog "It is recommended to run unrealircd as an unprivileged user."
+       elog "The provided init.d script does this for you."
+}