app-misc/ranger: update to EAPI 7 and add py38 support
authorTim Harder <radhermit@gentoo.org>
Mon, 18 Nov 2019 22:29:55 +0000 (15:29 -0700)
committerTim Harder <radhermit@gentoo.org>
Mon, 18 Nov 2019 22:29:55 +0000 (15:29 -0700)
Signed-off-by: Tim Harder <radhermit@gentoo.org>
app-misc/ranger/ranger-1.9.2.ebuild
app-misc/ranger/ranger-9999.ebuild

index 3cbf21455d0422364c6972e2490a753f7e6c550b..48aa1b9e69ef3e7c059bc8325d656e95dd89ef7d 100644 (file)
@@ -1,8 +1,8 @@
 # Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
-PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7,3_8} )
 PYTHON_REQ_USE="ncurses"
 
 inherit distutils-r1
@@ -19,11 +19,10 @@ DESCRIPTION="A vim-inspired file manager for the console"
 HOMEPAGE="https://ranger.github.io/"
 LICENSE="GPL-3"
 SLOT="0"
-IUSE="test"
-RESTRICT="!test? ( test )"
 
 RDEPEND="virtual/pager"
-DEPEND="test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest
 
 src_prepare() {
        # use versioned doc path
@@ -32,10 +31,6 @@ src_prepare() {
        distutils-r1_src_prepare
 }
 
-python_test() {
-       py.test -v tests/ranger || die "Tests failed under ${EPYTHON}"
-}
-
 pkg_postinst() {
        if [[ -z ${REPLACING_VERSIONS} ]]; then
                elog "Ranger has many optional dependencies to support enhanced file previews."
index 6d89ea92ccb9f2fd7bf6e7e4f7a38e039ba3bfdb..ab9b014fc86dfcc2572160268a3b97fb81fc87ef 100644 (file)
@@ -1,8 +1,8 @@
 # Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
-PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7,3_8} )
 PYTHON_REQ_USE="ncurses"
 
 inherit distutils-r1
@@ -19,11 +19,10 @@ DESCRIPTION="A vim-inspired file manager for the console"
 HOMEPAGE="https://ranger.github.io/"
 LICENSE="GPL-3"
 SLOT="0"
-IUSE="test"
-RESTRICT="!test? ( test )"
 
 RDEPEND="virtual/pager"
-DEPEND="test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest
 
 src_prepare() {
        # use versioned doc path
@@ -32,10 +31,6 @@ src_prepare() {
        distutils-r1_src_prepare
 }
 
-python_test() {
-       py.test -v tests/ranger || die "Tests failed under ${EPYTHON}"
-}
-
 pkg_postinst() {
        if [[ -z ${REPLACING_VERSIONS} ]]; then
                elog "Ranger has many optional dependencies to support enhanced file previews."