media-video/ffmpeg: neon is required on arm64, bug #610768.
authorAlexis Ballier <aballier@gentoo.org>
Sun, 26 Feb 2017 22:54:58 +0000 (23:54 +0100)
committerAlexis Ballier <aballier@gentoo.org>
Mon, 27 Feb 2017 08:34:02 +0000 (09:34 +0100)
See also: http://infocenter.arm.com/help/index.jsp?topic=/com.arm.doc.den0024a/CJHECGIH.html
Both floating-point and NEON are required in all standard ARMv8 implementations.

Package-Manager: Portage-2.3.3, Repoman-2.3.1

media-video/ffmpeg/ffmpeg-9999.ebuild

index 71ed7c1125bc1839dac8ade3208412ba8b309a5b..90445b61991fb4fc65118754649a5ca1125c0c4b 100644 (file)
@@ -126,6 +126,7 @@ X86_CPU_REQUIRED_USE="
        cpu_flags_x86_3dnowext?  ( cpu_flags_x86_3dnow )
        cpu_flags_x86_3dnow?  ( cpu_flags_x86_mmx )
 "
+ARM_CPU_REQUIRED_USE="arm64? ( neon )"
 
 IUSE="${IUSE}
        ${ARM_CPU_FEATURES[@]%:*}
@@ -135,6 +136,7 @@ IUSE="${IUSE}
 "
 
 CPU_REQUIRED_USE="
+       ${ARM_CPU_REQUIRED_USE}
        ${X86_CPU_REQUIRED_USE}
 "