dev-python/send2trash: add python3_8
authorAndrey Grozin <grozin@gentoo.org>
Sun, 1 Mar 2020 04:49:45 +0000 (11:49 +0700)
committerAndrey Grozin <grozin@gentoo.org>
Sun, 1 Mar 2020 04:49:45 +0000 (11:49 +0700)
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Andrey Grozin <grozin@gentoo.org>
dev-python/send2trash/send2trash-1.5.0-r1.ebuild [new file with mode: 0644]

diff --git a/dev-python/send2trash/send2trash-1.5.0-r1.ebuild b/dev-python/send2trash/send2trash-1.5.0-r1.ebuild
new file mode 100644 (file)
index 0000000..748e6b5
--- /dev/null
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+MY_PN="Send2Trash"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Sends files to the Trash (or Recycle Bin)"
+HOMEPAGE="
+       https://pypi.org/project/Send2Trash/
+       https://github.com/hsoft/send2trash"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+       dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}"/${MY_P}
+
+PATCHES=(
+       "${FILESDIR}/${P}-fix-broken-tests-on-py2.patch"
+)
+
+python_test() {
+       ${EPYTHON} setup.py test
+}