dev-php/pecl-amqp: Revbump adding 7.4, dropping 5.6 and 7.0
authorBrian Evans <grknight@gentoo.org>
Mon, 14 Oct 2019 13:38:01 +0000 (09:38 -0400)
committerBrian Evans <grknight@gentoo.org>
Tue, 15 Oct 2019 13:12:47 +0000 (09:12 -0400)
Package-Manager: Portage-2.3.76, Repoman-2.3.17
Signed-off-by: Brian Evans <grknight@gentoo.org>
dev-php/pecl-amqp/pecl-amqp-1.9.4-r1.ebuild [new file with mode: 0644]

diff --git a/dev-php/pecl-amqp/pecl-amqp-1.9.4-r1.ebuild b/dev-php/pecl-amqp/pecl-amqp-1.9.4-r1.ebuild
new file mode 100644 (file)
index 0000000..f609037
--- /dev/null
@@ -0,0 +1,24 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+USE_PHP="php7-1 php7-2 php7-3 php7-4"
+
+inherit php-ext-pecl-r3
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="PHP Bindings for AMQP 0-9-1 compatible brokers"
+LICENSE="PHP-3.01"
+SLOT="0"
+IUSE=""
+
+# Tests require running rabbitmq-server on localhost which requires epmd
+# which only accepts /var/run/epmd.pid as pidfile.
+RESTRICT="test"
+
+BDEPEND="virtual/pkgconfig"
+RDEPEND=">=net-libs/rabbitmq-c-0.5.2:=[ssl]"
+DEPEND="${RDEPEND}"
+PHP_EXT_ECONF_ARGS=()