dev-haskell/maccatcher: update to EAPI=6
authorSergei Trofimovich <slyfox@gentoo.org>
Tue, 10 May 2016 21:52:18 +0000 (22:52 +0100)
committerSergei Trofimovich <slyfox@gentoo.org>
Wed, 11 May 2016 08:48:03 +0000 (09:48 +0100)
Package-Manager: portage-2.2.28

dev-haskell/maccatcher/maccatcher-2.1.5-r1.ebuild [new file with mode: 0644]
dev-haskell/maccatcher/maccatcher-2.1.5.ebuild [deleted file]

diff --git a/dev-haskell/maccatcher/maccatcher-2.1.5-r1.ebuild b/dev-haskell/maccatcher/maccatcher-2.1.5-r1.ebuild
new file mode 100644 (file)
index 0000000..d098c9b
--- /dev/null
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+# ebuild generated by hackport 0.4.7.9999
+#hackport: flags: +split-base,+cli
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Obtain the host MAC address on *NIX and Windows"
+HOMEPAGE="http://hackage.haskell.org/package/maccatcher"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/binary:=[profile?]
+       dev-haskell/parsec:=[profile?]
+       >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+       >=dev-haskell/cabal-1.6
+"
+
+src_configure() {
+       haskell-cabal_src_configure \
+               --flag=cli \
+               --flag=split-base
+}
diff --git a/dev-haskell/maccatcher/maccatcher-2.1.5.ebuild b/dev-haskell/maccatcher/maccatcher-2.1.5.ebuild
deleted file mode 100644 (file)
index adee13f..0000000
+++ /dev/null
@@ -1,25 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-# ebuild generated by hackport 0.2.13
-
-EAPI="3"
-
-CABAL_FEATURES="bin lib profile haddock hscolour"
-inherit haskell-cabal
-
-DESCRIPTION="Obtain the host MAC address on *NIX and Windows"
-HOMEPAGE="http://hackage.haskell.org/package/maccatcher"
-SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND="dev-haskell/binary
-               dev-haskell/parsec
-               >=dev-lang/ghc-6.8.2"
-DEPEND="${RDEPEND}
-               >=dev-haskell/cabal-1.6"