dev-ml/ocaml-hashcons: bump to 1.3
authorAlexis Ballier <aballier@gentoo.org>
Fri, 1 Sep 2017 07:54:11 +0000 (09:54 +0200)
committerAlexis Ballier <aballier@gentoo.org>
Fri, 1 Sep 2017 11:18:39 +0000 (13:18 +0200)
Package-Manager: Portage-2.3.8, Repoman-2.3.3

dev-ml/ocaml-hashcons/Manifest
dev-ml/ocaml-hashcons/ocaml-hashcons-1.3.ebuild [new file with mode: 0644]

index 3a72ad97c90da2d4e29ea9e911473730e9ee39d9..6a368ba585c087a05fb256e9af91a53b3fa92abc 100644 (file)
@@ -1 +1,2 @@
 DIST ocaml-hashcons-1.2.tar.gz 19775 SHA256 de48e8e3e19b8cf84fb4d8d2484f0bb44dc6ced160b0d22b74d4de7236c821bb SHA512 167ed8d74c5080ef14af0ac1232ea16faee3f0e09e0a65cd72447266939ce7ed5416f4cf6a3021e5ca8215726df129d3f05c9e0c12dcd36f845b060fd93072b2 WHIRLPOOL 4d89bbf99826dbc1e5d8e46f03d71357b0b6c6b71ba76f9b7a8dcaa4906b976c4edd30407d0d1cb183e9cb5ef8b11f412fee98beb8eb1d4a6113cc9650eea0a3
+DIST ocaml-hashcons-1.3.tar.gz 19495 SHA256 59c72966f48ea67c694dd49099eca180b52d3da81d4300172ace6edb4a5d72ce SHA512 fd194d48a3231e72ca8bf3d324e5e1f6442d965da9149973a1763cf70aa82398805fa00648bdd12de3d3daada8e90bdc575c73886f949b5183e79bea75beadc8 WHIRLPOOL 67133d354bc96bfbffa269593680183cfd8bf8882383fdddd6a84fccb8702ab5aae440b0d428b19c2f2408ac95d501f654ec678d71c575b2f6d0f38ac8a0b4e0
diff --git a/dev-ml/ocaml-hashcons/ocaml-hashcons-1.3.ebuild b/dev-ml/ocaml-hashcons/ocaml-hashcons-1.3.ebuild
new file mode 100644 (file)
index 0000000..7b02796
--- /dev/null
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit autotools findlib
+
+DESCRIPTION="OCaml hash-consing library"
+HOMEPAGE="https://github.com/backtracking/ocaml-hashcons"
+SRC_URI="https://github.com/backtracking/ocaml-hashcons/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="+ocamlopt"
+
+RDEPEND="dev-lang/ocaml:=[ocamlopt?]"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+       eautoreconf
+       sed -i -e 's/$(OCAMLFIND) remove/#/' Makefile.in || die
+}
+
+src_compile() {
+       if use ocamlopt; then
+               emake opt byte
+       else
+               emake byte
+       fi
+}
+
+src_install() {
+       dodir "$(ocamlfind printconf destdir)/hashcons"
+       emake DESTDIR="-destdir ${D}/$(ocamlfind printconf destdir)/" $(usex ocamlopt install-opt install-byte)
+       dodoc README.md CHANGES
+}