media-plugins/gst-transcoder: bump to 1.14.1, fix LICENSE
authorMart Raudsepp <leio@gentoo.org>
Sat, 9 May 2020 16:12:20 +0000 (19:12 +0300)
committerMart Raudsepp <leio@gentoo.org>
Sat, 9 May 2020 16:20:33 +0000 (19:20 +0300)
There is also a 1.16.0, but that requires gst1.16, and we want to
fast-stabilize gst-transcoder to fix pitivi to not be so completely
broken.

As we now use meson.eclass properly (back when previous was added, that
didn't exist and we used the compatibility ./configure from upstream that
called meson), we don't dep on python ourselves anymore and if there
are any remaining CC or other toolchain env var honoring issues, it's
not our problem, but a generic meson.eclass related one.

Closes: https://bugs.gentoo.org/718338
Closes: https://bugs.gentoo.org/634408
Closes: https://bugs.gentoo.org/622396
Closes: https://bugs.gentoo.org/608032
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Mart Raudsepp <leio@gentoo.org>
media-plugins/gst-transcoder/Manifest
media-plugins/gst-transcoder/gst-transcoder-1.14.1.ebuild [new file with mode: 0644]

index 1a8ddf90316f3c4af26b00cca23cf3c1b4b70952..dbf040ff23058897f06a61f30d9fbb7f27df2b34 100644 (file)
@@ -1 +1,2 @@
+DIST gst-transcoder-1.14.1.tar.gz 37919 BLAKE2B 2687150ff3d609245449135d5725840aab9ed83b487bebeb0daf86634db27b3e68a5aca6ec8fb21ae5bf7e3c3808bc8729db5b24f75dabdf2bff7715a456fb9e SHA512 22dcb75bb706193e67a840218a69df797d5f833935e87d8df03838def5d426d94b25972ca4db8ae2f20fea915d18ef0044ee928a2dfe240f3134cdf1fced7657
 DIST gst-transcoder-1.8.2.tar.gz 29884 BLAKE2B 1004f038f50db87c98cf7c6a9645a25b0e532daf3b80188444990a672f595f9a64b002e479c73448c03dbb1bebd70929d4d560cf172021535aa26f5d33a5ecc7 SHA512 cabb3b0eacf018248a176fcc5b077fd8b0f9caab3d7853810809f5e2954b1c1fe62c9511453dc8a87fa930066c7c71e0d01ef86900c982eb5fc8a2769ada8494
diff --git a/media-plugins/gst-transcoder/gst-transcoder-1.14.1.ebuild b/media-plugins/gst-transcoder/gst-transcoder-1.14.1.ebuild
new file mode 100644 (file)
index 0000000..19047ce
--- /dev/null
@@ -0,0 +1,44 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit gnome2-utils meson xdg
+
+DESCRIPTION="GStreamer Transcoding API"
+HOMEPAGE="https://github.com/pitivi/gst-transcoder"
+SRC_URI="https://github.com/pitivi/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gtk-doc"
+
+RDEPEND="
+       dev-libs/gobject-introspection:=
+       dev-libs/glib:2
+       >=media-libs/gstreamer-${PV}:1.0[introspection]
+       >=media-libs/gst-plugins-base-${PV}:1.0[introspection]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+       gtk-doc? ( dev-util/gtk-doc
+               app-text/docbook-xml-dtd:4.1.2 )
+       virtual/pkgconfig
+"
+
+src_prepare() {
+       xdg_src_prepare
+       gnome2_environment_reset # fixes gst /dev access under sandbox for g-ir-scanner
+}
+
+src_configure() {
+       addwrite /dev/dri/
+       local emesonargs=(
+               $(meson_use !gtk-doc disable_doc)
+               # gobject-introspection can be optional now, but the only consumer (pitivi) requires it.
+               # Migration to have the option is not done, as gst-transcoder moves into gst-plugins-bad-1.18 anyhow.
+               -Ddisable_introspection=false
+       )
+       meson_src_configure
+}