Delete patches to fix key-sobst.
authorLuca Longinotti <chtekk@gentoo.org>
Fri, 17 Nov 2006 20:36:12 +0000 (20:36 +0000)
committerLuca Longinotti <chtekk@gentoo.org>
Fri, 17 Nov 2006 20:36:12 +0000 (20:36 +0000)
dev-db/libpq/files/libpq-7.3.16-gentoo.patch [deleted file]
dev-db/libpq/files/libpq-7.4.14-gentoo.patch [deleted file]

diff --git a/dev-db/libpq/files/libpq-7.3.16-gentoo.patch b/dev-db/libpq/files/libpq-7.3.16-gentoo.patch
deleted file mode 100644 (file)
index 254dafd..0000000
+++ /dev/null
@@ -1,54 +0,0 @@
-diff -Nru postgresql-7.3.16.orig/src/interfaces/libpq/Makefile postgresql-7.3.16/src/interfaces/libpq/Makefile
---- postgresql-7.3.16.orig/src/interfaces/libpq/Makefile       2006-11-05 13:20:09.000000000 +0100
-+++ postgresql-7.3.16/src/interfaces/libpq/Makefile    2006-11-05 13:21:19.000000000 +0100
-@@ -18,6 +18,8 @@
- SO_MAJOR_VERSION= 3
- SO_MINOR_VERSION= 0
-+NAME_STATIC_LIB= $(NAME)-$(SO_MAJOR_VERSION)
-+
- override CPPFLAGS := -I$(srcdir) $(CPPFLAGS) -DFRONTEND -DSYSCONFDIR='"$(sysconfdir)"'
- OBJS= fe-auth.o fe-connect.o fe-exec.o fe-misc.o fe-print.o fe-lobj.o \
-diff -Nru postgresql-7.3.16.orig/src/interfaces/libpq/nls.mk postgresql-7.3.16/src/interfaces/libpq/nls.mk
---- postgresql-7.3.16.orig/src/interfaces/libpq/nls.mk 2006-11-05 13:20:09.000000000 +0100
-+++ postgresql-7.3.16/src/interfaces/libpq/nls.mk      2006-11-05 13:21:19.000000000 +0100
-@@ -1,5 +1,5 @@
- # $Header: /cvsroot/pgsql/src/interfaces/libpq/nls.mk,v 1.8 2002/09/22 20:57:21 petere Exp $
--CATALOG_NAME  := libpq
-+CATALOG_NAME  := libpq-3
- AVAIL_LANGUAGES       := cs de es fr pt_BR ru sv zh_CN zh_TW
- GETTEXT_FILES := fe-auth.c fe-connect.c fe-exec.c fe-lobj.c fe-misc.c fe-secure.c
- GETTEXT_TRIGGERS:= libpq_gettext
-diff -Nru postgresql-7.3.16.orig/src/Makefile.shlib postgresql-7.3.16/src/Makefile.shlib
---- postgresql-7.3.16.orig/src/Makefile.shlib  2006-11-05 13:20:09.000000000 +0100
-+++ postgresql-7.3.16/src/Makefile.shlib       2006-11-05 13:23:20.000000000 +0100
-@@ -221,7 +221,7 @@
- all-lib: all-static-lib all-shared-lib
--all-static-lib: lib$(NAME).a
-+all-static-lib: lib$(NAME_STATIC_LIB).a
- all-shared-lib: $(shlib)
-@@ -231,7 +231,7 @@
- MK_NO_LORDER := true
- endif
--lib$(NAME).a: $(OBJS)
-+lib$(NAME_STATIC_LIB).a: $(OBJS)
- ifdef MK_NO_LORDER
-       $(LINK.static) $@ $^
- else
-@@ -302,8 +302,8 @@
- .PHONY: install-lib install-lib-static install-lib-shared
- install-lib: install-lib-static install-lib-shared
--install-lib-static: lib$(NAME).a
--      $(INSTALL_STLIB) $< $(DESTDIR)$(libdir)/lib$(NAME).a
-+install-lib-static: lib$(NAME_STATIC_LIB).a
-+      $(INSTALL_STLIB) $< $(DESTDIR)$(libdir)/lib$(NAME_STATIC_LIB).a
- ifeq ($(enable_shared), yes)
- install-lib-shared: $(shlib)
diff --git a/dev-db/libpq/files/libpq-7.4.14-gentoo.patch b/dev-db/libpq/files/libpq-7.4.14-gentoo.patch
deleted file mode 100644 (file)
index b2a9730..0000000
+++ /dev/null
@@ -1,67 +0,0 @@
-diff -Nru postgresql-7.4.14.orig/src/interfaces/libpq/Makefile postgresql-7.4.14/src/interfaces/libpq/Makefile
---- postgresql-7.4.14.orig/src/interfaces/libpq/Makefile       2006-11-05 13:20:18.000000000 +0100
-+++ postgresql-7.4.14/src/interfaces/libpq/Makefile    2006-11-05 13:23:46.000000000 +0100
-@@ -18,6 +18,8 @@
- SO_MAJOR_VERSION= 3
- SO_MINOR_VERSION= 1
-+NAME_STATIC_LIB= $(NAME)-$(SO_MAJOR_VERSION)
-+
- override CPPFLAGS := -I$(srcdir) $(CPPFLAGS) $(THREAD_CPPFLAGS) -DFRONTEND -DSYSCONFDIR='"$(sysconfdir)"'
- OBJS= fe-auth.o fe-connect.o fe-exec.o fe-misc.o fe-print.o fe-lobj.o \
-@@ -66,7 +68,7 @@
-       $(INSTALL_DATA) $(srcdir)/libpq-fe.h $(DESTDIR)$(includedir)
-       $(INSTALL_DATA) $(srcdir)/libpq-int.h $(DESTDIR)$(includedir_internal)
-       $(INSTALL_DATA) $(srcdir)/pqexpbuffer.h $(DESTDIR)$(includedir_internal)
--      $(INSTALL_DATA) $(srcdir)/pg_service.conf.sample $(DESTDIR)$(datadir)/pg_service.conf.sample
-+      $(INSTALL_DATA) $(srcdir)/pg_service.conf.sample $(DESTDIR)$(datadir)/pg_service-$(SO_MAJOR_VERSION).conf.sample
- installdirs:
-       $(mkinstalldirs) $(DESTDIR)$(libdir) $(DESTDIR)$(includedir) $(DESTDIR)$(includedir_internal)
-diff -Nru postgresql-7.4.14.orig/src/interfaces/libpq/nls.mk postgresql-7.4.14/src/interfaces/libpq/nls.mk
---- postgresql-7.4.14.orig/src/interfaces/libpq/nls.mk 2006-11-05 13:20:18.000000000 +0100
-+++ postgresql-7.4.14/src/interfaces/libpq/nls.mk      2006-11-05 13:23:46.000000000 +0100
-@@ -1,5 +1,5 @@
- # $Header: /cvsroot/pgsql/src/interfaces/libpq/nls.mk,v 1.13.2.1 2004/10/30 08:22:16 petere Exp $
--CATALOG_NAME  := libpq
-+CATALOG_NAME  := libpq-3
- AVAIL_LANGUAGES       := cs de es fr hr it nb pt_BR ru sl sv tr zh_CN zh_TW
- GETTEXT_FILES := fe-auth.c fe-connect.c fe-exec.c fe-lobj.c fe-misc.c fe-secure.c
- GETTEXT_TRIGGERS:= libpq_gettext pqInternalNotice:2
-diff -Nru postgresql-7.4.14.orig/src/Makefile.shlib postgresql-7.4.14/src/Makefile.shlib
---- postgresql-7.4.14.orig/src/Makefile.shlib  2006-11-05 13:20:18.000000000 +0100
-+++ postgresql-7.4.14/src/Makefile.shlib       2006-11-05 13:23:46.000000000 +0100
-@@ -229,7 +229,7 @@
- all-lib: all-static-lib all-shared-lib
--all-static-lib: lib$(NAME).a
-+all-static-lib: lib$(NAME_STATIC_LIB).a
- all-shared-lib: $(shlib)
-@@ -239,7 +239,7 @@
- MK_NO_LORDER := true
- endif
--lib$(NAME).a: $(OBJS)
-+lib$(NAME_STATIC_LIB).a: $(OBJS)
- ifdef MK_NO_LORDER
-       $(LINK.static) $@ $^
- else
-@@ -310,11 +310,11 @@
- .PHONY: install-lib install-lib-static install-lib-shared
- install-lib: install-lib-static install-lib-shared
--install-lib-static: lib$(NAME).a
--      $(INSTALL_STLIB) $< $(DESTDIR)$(libdir)/lib$(NAME).a
-+install-lib-static: lib$(NAME_STATIC_LIB).a
-+      $(INSTALL_STLIB) $< $(DESTDIR)$(libdir)/lib$(NAME_STATIC_LIB).a
- ifeq ($(PORTNAME), darwin)
-       cd $(DESTDIR)$(libdir) && \
--      ranlib lib$(NAME).a
-+      ranlib lib$(NAME_STATIC_LIB).a
- endif
- ifeq ($(enable_shared), yes)