Remove old ebuilds and unused patches. Use emake install instead of einstall. Don...
authorAndrej Kacian <ticho@gentoo.org>
Fri, 5 Jan 2007 16:52:04 +0000 (16:52 +0000)
committerAndrej Kacian <ticho@gentoo.org>
Fri, 5 Jan 2007 16:52:04 +0000 (16:52 +0000)
Package-Manager: portage-2.1.2_rc4-r1

net-mail/fetchmail/ChangeLog
net-mail/fetchmail/fetchmail-6.3.4.ebuild
net-mail/fetchmail/fetchmail-6.3.5-r1.ebuild
net-mail/fetchmail/fetchmail-6.3.5.ebuild

index e33a7cf97681505fc441bdf50335f66b6a497316..9b72217009678c08ed995e6493f63298011e1778 100644 (file)
@@ -1,6 +1,16 @@
 # ChangeLog for net-mail/fetchmail
 # Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/fetchmail/ChangeLog,v 1.112 2007/01/05 08:59:13 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/fetchmail/ChangeLog,v 1.113 2007/01/05 16:52:04 ticho Exp $
+
+  05 Jan 2007; Andrej Kacian <ticho@gentoo.org>
+  -files/fetchmail-6.2.5-gentoo.patch,
+  -files/fetchmail-6.2.5-kerberos.patch, -fetchmail-6.2.5.2-r1.ebuild,
+  -fetchmail-6.3.2.ebuild, -fetchmail-6.3.2-r1.ebuild,
+  -fetchmail-6.3.3.ebuild, fetchmail-6.3.4.ebuild, fetchmail-6.3.5.ebuild,
+  fetchmail-6.3.5-r1.ebuild:
+  Remove old ebuilds and unused patches. Use emake install instead of
+  einstall. Don't run autoconf, since we only apply patches to source files,
+  not to autofoo templates. Closes bug #160170.
 
   05 Jan 2007; Diego Pettenò <flameeyes@gentoo.org>
   fetchmail-6.2.5.2-r1.ebuild, fetchmail-6.3.2.ebuild,
index 923e1e67a29a3d1be5200e9a831153f118de8e44..b9955296826fbb4c4287f7f50fc67cd6be0c27c4 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/fetchmail/fetchmail-6.3.4.ebuild,v 1.13 2007/01/05 08:59:13 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/fetchmail/fetchmail-6.3.4.ebuild,v 1.14 2007/01/05 16:52:04 ticho Exp $
 
 inherit eutils
 
@@ -15,23 +15,18 @@ SLOT="0"
 KEYWORDS="alpha amd64 hppa ia64 mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
 IUSE="ssl nls ipv6 kerberos krb4 hesiod"
 
-RDEPEND="hesiod? ( net-dns/hesiod )
+DDEPEND="hesiod? ( net-dns/hesiod )
        ssl? ( >=dev-libs/openssl-0.9.6 )
        kerberos? ( app-crypt/mit-krb5 )
        nls? ( sys-devel/gettext )
        elibc_FreeBSD? ( sys-libs/com_err )"
 
-DEPEND="${RDEPEND}
-       sys-devel/autoconf"
-
 src_unpack() {
        unpack ${A} || die "unpack failed"
        cd ${S} || die "cd \${S} failed"
 
        # this patch fixes bug #34788 (ticho@gentoo.org 2004-09-03)
        epatch ${FILESDIR}/${PN}-6.2.5-broken-headers.patch || die
-
-       autoconf
 }
 
 src_compile() {
@@ -51,13 +46,14 @@ src_compile() {
 }
 
 src_install() {
-       einstall || die
+       emake DESTDIR="${D}" install || die "Install failed"
 
        dohtml *.html
 
        dodoc FAQ FEATURES ABOUT-NLS NEWS NOTES README \
                README.NTLM README.SSL TODO COPYING
 
+       # Put installed manpages to correct place
        doman ${D}/usr/share/man/*.1
        rm -f ${D}/usr/share/man/*.1
 
index 51ef158e998c0dfd4b392bb7ab2321cf5de2d9e2..fa4e9a7fdf5d23c803d51fc2d00a6077ace29414 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/fetchmail/fetchmail-6.3.5-r1.ebuild,v 1.2 2007/01/05 08:59:13 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/fetchmail/fetchmail-6.3.5-r1.ebuild,v 1.3 2007/01/05 16:52:04 ticho Exp $
 
 inherit eutils
 
@@ -16,15 +16,12 @@ KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86
 ~x86-fbsd"
 IUSE="ssl nls ipv6 kerberos krb4 hesiod"
 
-RDEPEND="hesiod? ( net-dns/hesiod )
+DEPEND="hesiod? ( net-dns/hesiod )
        ssl? ( >=dev-libs/openssl-0.9.6 )
        kerberos? ( app-crypt/mit-krb5 )
        nls? ( sys-devel/gettext )
        elibc_FreeBSD? ( sys-libs/com_err )"
 
-DEPEND="${RDEPEND}
-       sys-devel/autoconf"
-
 src_unpack() {
        unpack ${A} || die "unpack failed"
        cd ${S} || die "cd \${S} failed"
@@ -34,8 +31,6 @@ src_unpack() {
 
        # fix log weirdness
        epatch ${FILESDIR}/${PN}-6.3.5-preserve-logging-fd.patch
-
-       autoconf
 }
 
 src_compile() {
@@ -55,7 +50,7 @@ src_compile() {
 }
 
 src_install() {
-       einstall || die
+       emake DESTDIR="${D}" install || die
 
        dohtml *.html
 
index 8cdf4ed3c14e4d4ad2192a9b3d20c1db4a179137..3c0d40506bb307d5fea4085b27e5a7a2f0970139 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/fetchmail/fetchmail-6.3.5.ebuild,v 1.2 2007/01/05 08:59:13 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/fetchmail/fetchmail-6.3.5.ebuild,v 1.3 2007/01/05 16:52:04 ticho Exp $
 
 inherit eutils
 
@@ -16,23 +16,18 @@ KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86
 ~x86-fbsd"
 IUSE="ssl nls ipv6 kerberos krb4 hesiod"
 
-RDEPEND="hesiod? ( net-dns/hesiod )
+DEPEND="hesiod? ( net-dns/hesiod )
        ssl? ( >=dev-libs/openssl-0.9.6 )
        kerberos? ( app-crypt/mit-krb5 )
        nls? ( sys-devel/gettext )
        elibc_FreeBSD? ( sys-libs/com_err )"
 
-DEPEND="${RDEPEND}
-       sys-devel/autoconf"
-
 src_unpack() {
        unpack ${A} || die "unpack failed"
        cd ${S} || die "cd \${S} failed"
 
        # this patch fixes bug #34788 (ticho@gentoo.org 2004-09-03)
        epatch ${FILESDIR}/${PN}-6.2.5-broken-headers.patch || die
-
-       autoconf
 }
 
 src_compile() {
@@ -52,13 +47,14 @@ src_compile() {
 }
 
 src_install() {
-       einstall || die
+       emake DESTDIR="${D}" install || die
 
        dohtml *.html
 
        dodoc FAQ FEATURES ABOUT-NLS NEWS NOTES README \
                README.NTLM README.SSL TODO COPYING
 
+       # Put installed manpages to correct place
        doman ${D}/usr/share/man/*.1
        rm -f ${D}/usr/share/man/*.1