dev-ml/camlp4: bump to 4.04_p1
authorAlexis Ballier <aballier@gentoo.org>
Tue, 29 Nov 2016 14:54:12 +0000 (15:54 +0100)
committerAlexis Ballier <aballier@gentoo.org>
Tue, 29 Nov 2016 15:05:23 +0000 (16:05 +0100)
Package-Manager: portage-2.3.2

dev-ml/camlp4/Manifest
dev-ml/camlp4/camlp4-4.04_p1.ebuild [new file with mode: 0644]

index 5431eba5102649d667cd64ad972977086b23df1f..40cc1279808f4fade3668f4ce8287072d3000224 100644 (file)
@@ -1,2 +1,3 @@
 DIST camlp4-4.02.1_p3.tar.gz 646389 SHA256 c28058b20016dac51d492b1a98e6453d2c7097100542c99a0593cc240a3eeada SHA512 59d196be0bb7410ffd48a3d2debff4502ca58e7b032027b27b9d126381c02336f177a47585a7d7a3142049930c21dbe075068852e6369fe7e8a58e3339d96041 WHIRLPOOL bedcbaa86a1282bed6d51a64b1877575e727cbf2485abf38bcbed49b18cbad9e8548e0fb413daf216f3d78fde2710c95de49a5055cbb3548eb284515148a3e7d
 DIST camlp4-4.03_p1.tar.gz 648030 SHA256 6eefeacced81cca59ddf90c2538505fd5cd6596a3fc1acf4971e9796c2e7f2ae SHA512 0a329e18deffebb5245415f822f91e692076fca4dbe38748f18e72f417ce7354faed744fdff25f9976659192cb02d56ceb2cf1be5c64da463413ec4a28a9d3ac WHIRLPOOL a9aa6ff12957025ab796b02eec2268d51f71ebd64d395b0b5cad2d9d8bde91da4129f4f6606514c0e1b9480cf2e648158b0bdd6878ee29c3adadee64937bc87d
+DIST camlp4-4.04_p1.tar.gz 648320 SHA256 6044f24a44053684d1260f19387e59359f59b0605cdbf7295e1de42783e48ff1 SHA512 7db8eebcf3d230f60650ba62d9cb630c069394237e97b678a40b61d3dcaded752a2b7e089a50ff528f1ea0740d0291b722df123a072f2cee489cadc5201c6776 WHIRLPOOL 6cfed59e81dbd92debe23670657eb7e96125105fccb7b20a8e16553090cc9a0e8c732b8e0cac1a9b39e172aa8dfaae145ba8827948f371aeaa69345f3ba39096
diff --git a/dev-ml/camlp4/camlp4-4.04_p1.ebuild b/dev-ml/camlp4/camlp4-4.04_p1.ebuild
new file mode 100644 (file)
index 0000000..51f53e2
--- /dev/null
@@ -0,0 +1,44 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MY_PV=${PV/_p/+}
+MY_P=${PN}-${MY_PV}
+
+DESCRIPTION="System for writing extensible parsers for programming languages"
+HOMEPAGE="https://github.com/ocaml/camlp4"
+SRC_URI="https://github.com/ocaml/camlp4/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="+ocamlopt"
+
+DEPEND=">=dev-lang/ocaml-4.04_beta:=[ocamlopt?]"
+RDEPEND="${DEPEND}
+       !<dev-lang/ocaml-4.02
+       !<dev-ml/findlib-1.5.5-r1"
+DEPEND="${DEPEND}
+       || ( dev-ml/ocamlbuild <dev-lang/ocaml-4.02.3-r1 )"
+
+S=${WORKDIR}/${P/_p/-}
+
+src_configure() {
+       ./configure \
+               --bindir="${EPREFIX}/usr/bin" \
+               --libdir="$(ocamlc -where)" \
+               --pkgdir="$(ocamlc -where)" \
+               || die
+}
+
+src_compile() {
+       emake byte
+       use ocamlopt && emake native
+}
+
+src_install() {
+       emake DESTDIR="${D}" install install-META
+       dodoc CHANGES.md README.md
+}