dev-ruby/rexical: Fix build failures, bug 557296
authorPeter Wilmott <p8952@gentoo.org>
Fri, 14 Aug 2015 16:39:01 +0000 (17:39 +0100)
committerPeter Wilmott <p8952@gentoo.org>
Fri, 14 Aug 2015 16:39:01 +0000 (17:39 +0100)
Package-Manager: portage-2.2.20.1

dev-ruby/rexical/rexical-1.0.5-r2.ebuild

index 3f639309d2d034050d224038317ce1887cd17139..2a34436cc42edaa8cd5f61ce1a75d90cdd62bc69 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
@@ -27,8 +27,15 @@ ruby_add_bdepend "
        doc? ( >=dev-ruby/hoe-2.6.2 )
        test? (
                >=dev-ruby/hoe-2.6.2
+               dev-ruby/test-unit:2
        )"
 
+all_ruby_prepare() {
+       sed -i -e '1igem "test-unit"' test/test_generator.rb || die
+
+       sed -i -e '/rubyforge_name/d' Rakefile || die
+}
+
 all_ruby_install() {
        all_fakegem_install