dev-python/apipkg: Remove redundant versions
authorMichał Górny <mgorny@gentoo.org>
Thu, 26 Mar 2020 11:10:48 +0000 (12:10 +0100)
committerMichał Górny <mgorny@gentoo.org>
Thu, 26 Mar 2020 11:15:43 +0000 (12:15 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/apipkg/Manifest
dev-python/apipkg/apipkg-1.4.ebuild [deleted file]

index 79087bd2641602a737aed3afd986e87218edc2ae..e0432e73d85c37b3d33937dfd3e95176ef24501f 100644 (file)
@@ -1,2 +1 @@
-DIST apipkg-1.4.tar.gz 11224 BLAKE2B b59e3fe39030f1f1f7f41e121d7a4e242d7155be5f7b2b8f3cd7550772acceacaf2d9540cf98bdb51e6d132af937d634bce3699b950b9d9aa9a618009cbaebb8 SHA512 118f806706944513f50d3cdef596b32f8ce585cfaf94d2531a6d260f90a0e2147177161aaa6f5d6823150e6182d0f73be3dc01259b8a2f8d710733a22ea54789
 DIST apipkg-1.5.tar.gz 11186 BLAKE2B f703a37b38b412228348520a9daa0276a69c3be47a9586e1c2797cf525a024bb0fda81dbfad7d4b1404e1ebcd3eec0e9ce2231beef5072bf9915240e2e5fb445 SHA512 828937ca5e203915248fac54db8e7c13f941e006403f2a415c27fa4d1aa114790be3d7b5dd892f528611e5e6dfe75114ee80f4f4589a03c3f789ae6ddfcae0bf
diff --git a/dev-python/apipkg/apipkg-1.4.ebuild b/dev-python/apipkg/apipkg-1.4.ebuild
deleted file mode 100644 (file)
index b3a5ca2..0000000
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 python3_{6,7} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="namespace control and lazy-import mechanism"
-HOMEPAGE="https://pypi.org/project/apipkg/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 s390 ~sh sparc x86"
-IUSE="examples test"
-RESTRICT="!test? ( test )"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
-       dev-python/hgdistver[${PYTHON_USEDEP}]
-       test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
-
-python_test() {
-       py.test test_apipkg.py || die "Tests fail under ${EPYTHON}"
-}
-
-python_install_all() {
-       if use examples; then
-               docinto examples
-               dodoc -r example/.
-               docompress -x /usr/share/doc/${PF}/examples
-       fi
-
-       distutils-r1_python_install_all
-}