app-text/ghostscript-gpl: Version bump
authorAndreas K. Hüttel <dilfridge@gentoo.org>
Fri, 23 Nov 2018 00:19:56 +0000 (01:19 +0100)
committerAndreas K. Hüttel <dilfridge@gentoo.org>
Fri, 23 Nov 2018 00:19:56 +0000 (01:19 +0100)
Package-Manager: Portage-2.3.52, Repoman-2.3.12
Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
app-text/ghostscript-gpl/Manifest
app-text/ghostscript-gpl/ghostscript-gpl-9.26.ebuild [new file with mode: 0644]

index 70b25a2d84396170e481461ca855f8075341a5f2..8e812cb0f03ca22e3a12cbe910a367843b702614 100644 (file)
@@ -1,4 +1,6 @@
 DIST ghostscript-9.21.tar.xz 29164532 BLAKE2B 275e81e44585e186cdfd9f517d1ac77ec840c62ef01f107f6ec0131546c4a2b526000cbc4ba6a91b55eedb8f3783fbf831059d791ea441a484ce29dd5dd6af0e SHA512 cfea089b92fb01e3f7c18a9ce05e7165fc8b356e2914bf53b7f2fd9de672279c8b97ced07e983e619f0d4334ce16018b100cfbf0cc872c215a8cf2aff4c78731
 DIST ghostscript-9.25.tar.xz 33027708 BLAKE2B 7c6684898ef04bc5b6be8fec86adbf7b270107f4063b299175f5c08e5e7ace2468e1512a297464fda5695c830808916e6a0dd1202ca7e85b32cfd175d8cc2b18 SHA512 7a1c0b7546ed523f50c1452d4a1c13fcf043d6060fc9708bbc4b543f66ecb1b619b6e71998094ac702ef44a2fd159b6523271de19b1cae352981ef51fb637651
+DIST ghostscript-9.26.tar.xz 33059724 BLAKE2B 7ccb9730db8ae056e67bf8d7fa097a4cb529605e12214ab81253d2d354d26c24e393c8bec2ecdb51a1fefe8443b8af47758705c2fb6b1dab59932140c5de07ca SHA512 3ddb83029edf32282357bf606f4045a9ac73df6543cd423cfad09158ec12ada083a0dbb5aac3b73ae24cbc6c1e9d7574257a5c1fae63ba8776fbb00150ef2a3e
 DIST ghostscript-gpl-9.21-patchset-1.tar.xz 6196 BLAKE2B d2bccba582873d29c1724469af66a5aa72755d6ff73bbdadbf33e5eb4a2027c2cf14415319c3c3c6d03a9fbd9bad43e3bf7ef57eb7a3361305f6efb7fa550675 SHA512 58fef7080ca17a238231fb528be48f52bcfa771b1e496d7fede6df45fb927f1bb1c755cb77e02aa739295b0ccf0b3d3959f9a05a1628d32ffd11e134c0e0d355
 DIST ghostscript-gpl-9.25-patchset-1.tar.xz 3716 BLAKE2B 0a4c32b3d0c0152b0dc7c62bf2b0bc8e30a369c2aed7c7be4a231948123c2242ce96ae5b1fd485bdae84d7cde1be9f3b3a16831fe77dfbc7ac6cd28bb5e14442 SHA512 7ad9558b00cc11d0872b32d2f1430d2e47730a2360c79d88299c87f8d6d4c15adb5c679ebdcaf50c58d9051c6a1d6f6873e4d81aadfbf3ce202ad94b6dc8981f
+DIST ghostscript-gpl-9.26-patchset-1.tar.xz 3716 BLAKE2B 0a4c32b3d0c0152b0dc7c62bf2b0bc8e30a369c2aed7c7be4a231948123c2242ce96ae5b1fd485bdae84d7cde1be9f3b3a16831fe77dfbc7ac6cd28bb5e14442 SHA512 7ad9558b00cc11d0872b32d2f1430d2e47730a2360c79d88299c87f8d6d4c15adb5c679ebdcaf50c58d9051c6a1d6f6873e4d81aadfbf3ce202ad94b6dc8981f
diff --git a/app-text/ghostscript-gpl/ghostscript-gpl-9.26.ebuild b/app-text/ghostscript-gpl/ghostscript-gpl-9.26.ebuild
new file mode 100644 (file)
index 0000000..1ace983
--- /dev/null
@@ -0,0 +1,196 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools flag-o-matic toolchain-funcs
+
+DESCRIPTION="Interpreter for the PostScript language and PDF"
+HOMEPAGE="https://ghostscript.com/"
+
+MY_P=${P/-gpl}
+PVM=$(ver_cut 1-2)
+PVM_S=$(ver_rs 1-2 "")
+
+MY_PATCHSET=1
+
+SRC_URI="
+       https://github.com/ArtifexSoftware/ghostpdl-downloads/releases/download/gs${PVM_S}/${MY_P}.tar.xz
+       https://dev.gentoo.org/~dilfridge/distfiles/${P}-patchset-${MY_PATCHSET}.tar.xz
+"
+
+LICENSE="AGPL-3 CPL-1.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="cups dbus gtk l10n_de static-libs tiff unicode X"
+
+LANGS="ja ko zh-CN zh-TW"
+for X in ${LANGS} ; do
+       IUSE="${IUSE} l10n_${X}"
+done
+
+DEPEND="
+       app-text/libpaper
+       media-libs/fontconfig
+       >=media-libs/freetype-2.4.9:2=
+       media-libs/jbig2dec
+       >=media-libs/lcms-2.6:2
+       >=media-libs/libpng-1.6.2:0=
+       >=media-libs/openjpeg-2.1.0:2=
+       >=sys-libs/zlib-1.2.7
+       virtual/jpeg:0
+       cups? ( >=net-print/cups-1.3.8 )
+       dbus? ( sys-apps/dbus )
+       gtk? ( || ( x11-libs/gtk+:3 x11-libs/gtk+:2 ) )
+       unicode? ( net-dns/libidn:= )
+       tiff? ( >=media-libs/tiff-4.0.1:0= )
+       X? ( x11-libs/libXt x11-libs/libXext )
+"
+BDEPEND="virtual/pkgconfig"
+RDEPEND="${DEPEND}
+       app-text/poppler-data
+       >=media-fonts/urw-fonts-2.4.9
+       l10n_ja? ( media-fonts/kochi-substitute )
+       l10n_ko? ( media-fonts/baekmuk-fonts )
+       l10n_zh-CN? ( media-fonts/arphicfonts )
+       l10n_zh-TW? ( media-fonts/arphicfonts )
+"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+       # apply various patches, many borrowed from Fedora
+       # http://pkgs.fedoraproject.org/cgit/ghostscript.git
+       eapply "${WORKDIR}/patches/"*.patch
+       default
+
+       # remove internal copies of various libraries
+       rm -r cups/libs || die
+       rm -r freetype || die
+       rm -r jbig2dec || die
+       rm -r jpeg || die
+       rm -r lcms2mt || die
+       rm -r libpng || die
+       rm -r tiff || die
+       rm -r zlib || die
+       rm -r openjpeg || die
+       # remove internal CMaps (CMaps from poppler-data are used instead)
+       rm -r Resource/CMap || die
+
+       if ! use gtk ; then
+               sed -e "s:\$(GSSOX)::" \
+                       -e "s:.*\$(GSSOX_XENAME)$::" \
+                       -i base/unix-dll.mak || die "sed failed"
+       fi
+
+       # Force the include dirs to a neutral location.
+       sed -e "/^ZLIBDIR=/s:=.*:=${T}:" \
+               -i configure.ac || die
+       # Some files depend on zlib.h directly.  Redirect them. #573248
+       # Also make sure to not define OPJ_STATIC to avoid linker errors due to
+       # hidden symbols (https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=203327#c1)
+       sed -e '/^zlib_h/s:=.*:=:' \
+               -e 's|-DOPJ_STATIC ||' \
+               -i base/lib.mak || die
+
+       # search path fix
+       # put LDFLAGS after BINDIR, bug #383447
+       sed -e "s:\$\(gsdatadir\)/lib:@datarootdir@/ghostscript/${PVM}/$(get_libdir):" \
+               -e "s:exdir=.*:exdir=@datarootdir@/doc/${PF}/examples:" \
+               -e "s:docdir=.*:docdir=@datarootdir@/doc/${PF}/html:" \
+               -e "s:GS_DOCDIR=.*:GS_DOCDIR=@datarootdir@/doc/${PF}/html:" \
+               -e 's:-L$(BINDIR):& $(LDFLAGS):g' \
+               -i Makefile.in base/*.mak || die "sed failed"
+
+       # remove incorrect symlink, bug 590384
+       rm ijs/ltmain.sh || die
+       eautoreconf
+
+       cd ijs || die
+       eautoreconf
+}
+
+src_configure() {
+       local FONTPATH
+       for path in \
+               "${EPREFIX}"/usr/share/fonts/urw-fonts \
+               "${EPREFIX}"/usr/share/fonts/Type1 \
+               "${EPREFIX}"/usr/share/fonts \
+               "${EPREFIX}"/usr/share/poppler/cMap/Adobe-CNS1 \
+               "${EPREFIX}"/usr/share/poppler/cMap/Adobe-GB1 \
+               "${EPREFIX}"/usr/share/poppler/cMap/Adobe-Japan1 \
+               "${EPREFIX}"/usr/share/poppler/cMap/Adobe-Japan2 \
+               "${EPREFIX}"/usr/share/poppler/cMap/Adobe-Korea1
+       do
+               FONTPATH="$FONTPATH${FONTPATH:+:}${EPREFIX}$path"
+       done
+
+       PKGCONFIG=$(type -P $(tc-getPKG_CONFIG)) \
+       econf \
+               --enable-dynamic \
+               --enable-freetype \
+               --enable-fontconfig \
+               --enable-openjpeg \
+               --disable-compile-inits \
+               --with-drivers=ALL \
+               --with-fontpath="$FONTPATH" \
+               --with-ijs \
+               --with-jbig2dec \
+               --with-libpaper \
+               --without-luratech \
+               $(use_enable cups) \
+               $(use_enable dbus) \
+               $(use_enable gtk) \
+               $(use_with cups pdftoraster) \
+               $(use_with unicode libidn) \
+               $(use_with tiff system-libtiff) \
+               $(use_with X x)
+
+       cd "${S}/ijs" || die
+       econf \
+               --enable-shared \
+               $(use_enable static-libs static)
+}
+
+src_compile() {
+       emake so all
+
+       cd ijs || die
+       emake
+}
+
+src_install() {
+       emake DESTDIR="${D}" install-so install
+
+       # move gsc to gs, bug #343447
+       # gsc collides with gambit, bug #253064
+       mv -f "${ED}"/usr/bin/{gsc,gs} || die
+
+       cd "${S}/ijs" || die
+       emake DESTDIR="${D}" install
+
+       # rename the original cidfmap to cidfmap.GS
+       mv "${ED}/usr/share/ghostscript/${PVM}/Resource/Init/cidfmap"{,.GS} || die
+
+       # install our own cidfmap to handle CJK fonts
+       insinto /usr/share/ghostscript/${PVM}/Resource/Init
+       doins \
+               "${WORKDIR}/fontmaps/CIDFnmap" \
+               "${WORKDIR}/fontmaps/cidfmap"
+       for X in ${LANGS} ; do
+               if use l10n_${X} ; then
+                       doins "${WORKDIR}/fontmaps/cidfmap.${X/-/_}"
+               fi
+       done
+
+       # install the CMaps from poppler-data properly, bug #409361
+       dosym ../../../poppler/cMaps "/usr/share/ghostscript/${PVM}/Resource/CMap"
+
+       if ! use static-libs; then
+               find "${ED}" -name '*.la' -delete || die
+       fi
+
+       if ! use l10n_de; then
+               rm -r "${ED}"/usr/share/man/de || die
+       fi
+}