net-analyzer/nagios-core: fix cgi-bin path for apache
authorTomas Mozes <hydrapolic@gmail.com>
Thu, 14 Nov 2019 06:56:40 +0000 (07:56 +0100)
committerMichael Orlitzky <mjo@gentoo.org>
Thu, 14 Nov 2019 12:52:27 +0000 (07:52 -0500)
Bug: https://bugs.gentoo.org/699002
Package-Manager: Portage-2.3.79, Repoman-2.3.17
Signed-off-by: Tomáš Mózes <hydrapolic@gmail.com>
Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
net-analyzer/nagios-core/files/99_nagios4-r1.conf
net-analyzer/nagios-core/nagios-core-4.4.5-r5.ebuild [moved from net-analyzer/nagios-core/nagios-core-4.4.5-r4.ebuild with 97% similarity]

index 54531ed6275b1891234ae32936fabba37720c07e..8d080d5c17b1a746c9cf411c8682d56158516dfe 100644 (file)
@@ -1,6 +1,6 @@
 <IfDefine NAGIOS>
 
-  ScriptAlias /nagios/cgi-bin/ @CGIBINDIR@
+  ScriptAlias /nagios/cgi-bin @CGIBINDIR@
   <Directory "@CGIBINDIR@">
     AllowOverride AuthConfig
     Options ExecCGI
similarity index 97%
rename from net-analyzer/nagios-core/nagios-core-4.4.5-r4.ebuild
rename to net-analyzer/nagios-core/nagios-core-4.4.5-r5.ebuild
index 4a5ffee95d4fe6c75697c8a8f4c4bf2c949af940..a1922298fa0f5e73c859e09e1397f9d4cf892c6a 100644 (file)
@@ -105,8 +105,8 @@ src_configure() {
        # The paths in the web server configuration files need to match
        # those passed to econf above.
        cp "${FILESDIR}/99_nagios4-r1.conf" \
-          "${FILESDIR}/lighttpd_nagios4-r1.conf" \
-          "${T}/" || die "failed to create copies of web server conf files"
+               "${FILESDIR}/lighttpd_nagios4-r1.conf" \
+               "${T}/" || die "failed to create copies of web server conf files"
 
        sed -e "s|@CGIBINDIR@|${EPREFIX}/usr/$(get_libdir)/nagios/cgi-bin|g" \
                -e "s|@WEBDIR@|${EPREFIX}/usr/share/nagios/htdocs|" \
@@ -189,7 +189,7 @@ src_install() {
                if use apache2 ; then
                        # Install the Nagios configuration file for Apache.
                        insinto "/etc/apache2/modules.d"
-                       doins "${T}/99_nagios4-r1.conf"
+                       newins "${T}/99_nagios4-r1.conf" "99_nagios4.conf"
                elif use lighttpd ; then
                        # Install the Nagios configuration file for Lighttpd.
                        insinto /etc/lighttpd