dev-php/pecl-ssh2: Remove masked version
authorBrian Evans <grknight@gentoo.org>
Mon, 30 Dec 2019 14:27:15 +0000 (09:27 -0500)
committerBrian Evans <grknight@gentoo.org>
Mon, 30 Dec 2019 15:09:06 +0000 (10:09 -0500)
Bug: https://bugs.gentoo.org/651784
Signed-off-by: Brian Evans <grknight@gentoo.org>
dev-php/pecl-ssh2/Manifest
dev-php/pecl-ssh2/files/0.13-parse_url-fix.patch [deleted file]
dev-php/pecl-ssh2/pecl-ssh2-0.13-r3.ebuild [deleted file]
profiles/package.mask

index 55e27af2e95498dee5e1ec28cdd7a4c24e00c019..b87e771ebe29316bdf62f29b84456dd775adf2ca 100644 (file)
@@ -1,3 +1,2 @@
 DIST pecl-ssh2-1.2.tar.gz 32447 BLAKE2B 3a9d0f205097a381d07fb9dd5ab4dcb8e361f555dbc633abb8fa895c83024b70e85cd87602da1ceeb1018a7b07c474720b02810ef0689e9294fc33b129b6c738 SHA512 7b7d311cd5f88835e124d70a0295468f75d0fa6936a58808c936d1a185bb630b9e02c21f49b4bd777194a7b104aa3ff85c4fbf480f43d5906787e532ba2d3e04
-DIST ssh2-0.13.tgz 28984 BLAKE2B 3c18cb7aba146801325eeaca3ffb6e3780675a7ce6d78aea5fbc16f75662284f7773de2161789f68af0b5499e9cb813f4046d674758c138849eb6735344249f9 SHA512 c031e22853bf5cf8ee59dc5b99d9e7e60af1507a22e7d0a9e2f54b8f1758a03a6cea91c539e0f667d48ec66185fdc8a28c47e5a1e10a72220c0cb16b3948e1d0
 DIST ssh2-1.1.2.tgz 32057 BLAKE2B 88ffb3fb608687a086bbe345677982e944210791acc100312ba56ac7c35188a52cde5529d78caf473d19710e9965fba853ea9ff046715413a0b488ae2d8b690c SHA512 36793191448745b8a9b3cc628fe9fb431480792c7a2ff0bf2eccd58cda1cf944933be1d301c455d4a6f3dabf7e04ffef248bc402a8ff99bfafcba0deddb25c36
diff --git a/dev-php/pecl-ssh2/files/0.13-parse_url-fix.patch b/dev-php/pecl-ssh2/files/0.13-parse_url-fix.patch
deleted file mode 100644 (file)
index c9c052f..0000000
+++ /dev/null
@@ -1,49 +0,0 @@
-From 093906ec1c065e86ad1cd4dabbc89b1ccae11938 Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@php.net>
-Date: Thu, 10 Nov 2016 09:16:02 +0100
-Subject: [PATCH] fix for PHP 7.0.13 where php_url_parse fails
-
----
- ssh2_fopen_wrappers.c | 17 ++++++++++++-----
- 1 file changed, 12 insertions(+), 5 deletions(-)
-
-diff --git a/ssh2_fopen_wrappers.c b/ssh2_fopen_wrappers.c
-index 8472ddd..89b34eb 100644
---- a/ssh2_fopen_wrappers.c
-+++ b/ssh2_fopen_wrappers.c
-@@ -198,10 +198,20 @@ php_url *php_ssh2_fopen_wraper_parse_path(       char *path, char *type, php_stream_co
-       php_url *resource;
-       zval *methods = NULL, *callbacks = NULL, zsession, **tmpzval;
-       long resource_id;
--      char *s, *username = NULL, *password = NULL, *pubkey_file = NULL, *privkey_file = NULL;
-+      char *h, *s, *username = NULL, *password = NULL, *pubkey_file = NULL, *privkey_file = NULL;
-       int username_len = 0, password_len = 0;
--      resource = php_url_parse(path);
-+      h = strstr(path, "Resource id #");
-+      if (h) {
-+              /* Starting with 5.6.28, 7.0.13 need to be clean, else php_url_parse will fail */
-+              char *tmp = estrdup(path);
-+
-+              strncpy(tmp + (h-path), h + sizeof("Resource id #")-1, strlen(tmp)-sizeof("Resource id #"));
-+              resource = php_url_parse(tmp);
-+              efree(tmp);
-+      } else {
-+              resource = php_url_parse(path);
-+      }
-       if (!resource || !resource->path) {
-               return NULL;
-       }
-@@ -232,9 +242,6 @@ php_url *php_ssh2_fopen_wraper_parse_path( char *path, char *type, php_stream_co
-       /* Look for a resource ID to reuse a session */
-       s = resource->host;
--      if (strncmp(resource->host, "Resource id #", sizeof("Resource id #") - 1) == 0) {
--              s = resource->host + sizeof("Resource id #") - 1;
--      }
-       if (is_numeric_string(s, strlen(s), &resource_id, NULL, 0) == IS_LONG) {
-               php_ssh2_sftp_data *sftp_data;
--- 
-2.1.4
-
diff --git a/dev-php/pecl-ssh2/pecl-ssh2-0.13-r3.ebuild b/dev-php/pecl-ssh2/pecl-ssh2-0.13-r3.ebuild
deleted file mode 100644 (file)
index 25a9a72..0000000
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PHP_EXT_NAME="ssh2"
-
-USE_PHP="php5-6 php7-0 php7-1"
-
-inherit php-ext-pecl-r3
-
-USE_PHP="php5-6"
-
-DESCRIPTION="PHP bindings for the libssh2 library"
-LICENSE="PHP-3.01"
-SLOT="0"
-IUSE=""
-KEYWORDS="amd64 x86"
-# Upstream notes say there are errors with gcrypt backend
-DEPEND="net-libs/libssh2[-gcrypt]"
-RDEPEND="${DEPEND}"
-PDEPEND="php_targets_php7-0? ( dev-php/pecl-ssh2:7 )
-       php_targets_php7-1? ( dev-php/pecl-ssh2:7 )"
-
-src_prepare(){
-       if use php_targets_php5-6 ; then
-               local PATCHES=( "${FILESDIR}/0.13-parse_url-fix.patch" )
-               php-ext-source-r3_src_prepare
-       else
-               default_src_prepare
-       fi
-}
index 1e6771168cf079e94a65a3a69f3756b63e7c456a..7b927fab35c363574e246cb393c2862543ecc6ac 100644 (file)
@@ -780,7 +780,6 @@ virtual/httpd-php:5.6
 # Brian Evans <grknight@gentoo.org> (2019-10-01)
 # Old slots for support of PHP <7
 # Removal in 90 days. Bug 651784
-dev-php/pecl-ssh2:0
 dev-php/pecl-stomp:0
 dev-php/pecl-xdiff:0
 dev-php/pecl-yaml:0