old
authorMike Frysinger <vapier@gentoo.org>
Sat, 2 Dec 2006 20:34:27 +0000 (20:34 +0000)
committerMike Frysinger <vapier@gentoo.org>
Sat, 2 Dec 2006 20:34:27 +0000 (20:34 +0000)
dev-util/strace/files/digest-strace-4.5.11 [deleted file]
dev-util/strace/strace-4.5.11.ebuild [deleted file]

diff --git a/dev-util/strace/files/digest-strace-4.5.11 b/dev-util/strace/files/digest-strace-4.5.11
deleted file mode 100644 (file)
index 9099653..0000000
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 28335e15c83456a3db055a0a0efcb4fe strace-4.5.11.tar.bz2 422458
-RMD160 f86e775e04f08e0ac4c611ea7b9b0fa598960863 strace-4.5.11.tar.bz2 422458
-SHA256 9de428477d4d3f383d58c2f16b2544da2a5ec0acc50ee90ecb81dfe38f56edb8 strace-4.5.11.tar.bz2 422458
diff --git a/dev-util/strace/strace-4.5.11.ebuild b/dev-util/strace/strace-4.5.11.ebuild
deleted file mode 100644 (file)
index 4db9929..0000000
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/strace/strace-4.5.11.ebuild,v 1.4 2005/06/30 04:04:38 kumba Exp $
-
-inherit flag-o-matic
-
-DESCRIPTION="A useful diagnostic, instructional, and debugging tool"
-HOMEPAGE="http://sourceforge.net/projects/strace/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
-
-LICENSE="as-is"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 ~s390 sparc x86"
-IUSE="static"
-
-DEPEND=""
-
-src_unpack() {
-       unpack ${A}
-       cd ${S}
-
-       if [[ ${CTARGET:-${CHOST}} == *-freebsd* ]] ; then
-               epatch ${FILESDIR}/${P}-fbsd.patch
-               aclocal && autoconf && automake || die "autotools failed"
-       fi
-
-       # Hack until we can fix this properly
-       epatch ${FILESDIR}/strace-4.5.11-alpha-stat64.patch
-
-       # Remove some obsolete ia64-related hacks from the strace source
-       # (08 Feb 2005 agriffis)
-       epatch ${FILESDIR}/strace-4.5.8-ia64.patch
-
-       # This is ugly but linux26-headers-2.6.8.1-r2 (and other versions) has some
-       # issues with definition of s64 and friends.  This seems to solve
-       # compilation in this case (08 Feb 2005 agriffis)
-       use ia64 && append-flags -D_ASM_IA64_PAL_H
-
-       # Compile fails with -O3 on sparc but works on x86
-       use sparc && replace-flags -O[3-9] -O2
-       filter-lfs-flags
-
-       use static && append-ldflags -static
-}
-
-src_install() {
-       # Can't use make install because it is stupid and
-       # doesn't make leading directories before trying to
-       # install. Thus, one would have to make /usr/bin
-       # and /usr/man/man1 (at least).
-       # So, we do it by hand.
-       doman strace.1
-       dobin strace strace-graph || die
-       dodoc ChangeLog CREDITS NEWS PORTING README* TODO
-}