sys-libs/ncurses: fix cross tic path test #558622
authorMike Frysinger <vapier@gentoo.org>
Fri, 28 Aug 2015 17:37:40 +0000 (13:37 -0400)
committerMike Frysinger <vapier@gentoo.org>
Fri, 28 Aug 2015 17:38:35 +0000 (13:38 -0400)
sys-libs/ncurses/ncurses-5.9-r101.ebuild
sys-libs/ncurses/ncurses-6.0-r1.ebuild

index 00166f61aca91c2cc4f612c639c75376f28171f0..a90cf859b8d1c5197c089aed4e27933ee5a2ea20 100644 (file)
@@ -146,8 +146,8 @@ do_configure() {
        fi
        # See comments in src_configure.
        if [[ ${target} != "cross" ]] ; then
-               local tic_path="${WORKDIR}/cross/progs/tic"
-               [[ -d ${tic_path} ]] && export TIC_PATH=${tic_path}
+               local cross_path="${WORKDIR}/cross"
+               [[ -d ${cross_path} ]] && export TIC_PATH="${cross_path}/progs/tic"
        else
                conf+=( --with-progs )
        fi
index a8b1c1e686404112ae3a708ceb3839a30d17abd3..977da6d833488230a05c5d6a10b60342fa16b450 100644 (file)
@@ -159,8 +159,8 @@ do_configure() {
        fi
        # See comments in src_configure.
        if [[ ${target} != "cross" ]] ; then
-               local tic_path="${WORKDIR}/cross/progs/tic"
-               [[ -d ${tic_path} ]] && export TIC_PATH=${tic_path}
+               local cross_path="${WORKDIR}/cross"
+               [[ -d ${cross_path} ]] && export TIC_PATH="${cross_path}/progs/tic"
        fi
 
        # Force bash until upstream rebuilds the configure script with a newer