media-fonts/glass-tty-vt220: bump to EAPI=7
authorConrad Kostecki <conrad@kostecki.com>
Sun, 20 Oct 2019 10:38:16 +0000 (12:38 +0200)
committerJoonas Niilola <juippis@gentoo.org>
Wed, 23 Oct 2019 04:50:10 +0000 (07:50 +0300)
Also updated SRC_URI to use Github, since there is now a project.
Upstream also clarified a new license, so changed it.

Package-Manager: Portage-2.3.76, Repoman-2.3.17
Signed-off-by: Conrad Kostecki <conrad@kostecki.com>
Closes: https://github.com/gentoo/gentoo/pull/13359
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
media-fonts/glass-tty-vt220/Manifest
media-fonts/glass-tty-vt220/glass-tty-vt220-001.3-r1.ebuild [new file with mode: 0644]
media-fonts/glass-tty-vt220/metadata.xml

index 5281cb2d3b8c3128da824ef32a04f27a485e32a9..4b10e10b75b5fdce1911f9092c7e854eb2888f81 100644 (file)
@@ -1 +1,2 @@
 DIST Glass_TTY_VT220-001.3.ttf 88228 BLAKE2B 0ea3b0f47f280f4b58f3a0ab844ec69c3870c9cf12d7f1cf1124ffbdcd451988aafcf9aa714d42610d3bba44c352b93791a7a2457f1ad3cd2e690a3f058cfb61 SHA512 0b3b598bbdcc8f1177b48a7cedd2ad035a8a95d17d162d868e7c988a9d918f2756a8fe674bef3f30357225a87ea4e3adde01889502540d6920210161edc37023
+DIST glass-tty-vt220-001.3.tar.gz 23707 BLAKE2B 3fe67a3e34d405aff20addaacd4a7acdd9fb4632cbc7f277a715469fab3ba68ef6985e17e8bcd630264641ecc56cc0f9a2e08876ac94ed26b40175cac1709738 SHA512 9ed77e9cff5c1c59a9a93cb2caaebdc19d8057827165630882cbacb5cc79e15c6b90044d3a5e85bfc55c344a16128d499f15d6bdff8ef3091093b2b7790fbedc
diff --git a/media-fonts/glass-tty-vt220/glass-tty-vt220-001.3-r1.ebuild b/media-fonts/glass-tty-vt220/glass-tty-vt220-001.3-r1.ebuild
new file mode 100644 (file)
index 0000000..1a7ec02
--- /dev/null
@@ -0,0 +1,38 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+EGIT_COMMIT="8d5bcafe971ee94df4aa20317f197d407df672e9"
+MY_PN="glasstty"
+
+inherit font
+
+DESCRIPTION="Hacking with Style: TrueType VT220 Font"
+HOMEPAGE="
+       http://sensi.org/~svo/glasstty/
+       https://github.com/svofski/glasstty
+"
+SRC_URI="https://github.com/svofski/${MY_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+LICENSE="Unlicense"
+SLOT="0"
+
+S="${WORKDIR}/${MY_PN}-${EGIT_COMMIT}"
+
+FONT_S="${S}"
+FONT_SUFFIX="ttf"
+
+src_configure() {
+       :;
+}
+
+src_compile() {
+       :;
+}
+
+pkg_postinst() {
+       einfo "Since the GlassTTY VT220 font is fixed,"
+       einfo "you must use a font size of 15 for best quality."
+}
index 91f4fc444d2135fe7aaa1ff6e8cd92878397dd94..029a9e3f33524d8b673beff381bbcbdf7e0fbf20 100644 (file)
@@ -18,4 +18,8 @@
                is lacking and nostalgic value is absent. What I wanted was a font that
                fills my virtual terminal window with the magic hacking glow.
        </longdescription>
+       <upstream>
+               <bugs-to>https://github.com/svofski/glasstty/issues</bugs-to>
+               <remote-id type="github">svofski/glasstty</remote-id>
+       </upstream>
 </pkgmetadata>