dev-libs/libgit2: Bump to 0.26.2 security bugfix
authorMichał Górny <mgorny@gentoo.org>
Fri, 9 Mar 2018 07:24:45 +0000 (08:24 +0100)
committerMichał Górny <mgorny@gentoo.org>
Fri, 9 Mar 2018 07:27:40 +0000 (08:27 +0100)
dev-libs/libgit2/Manifest
dev-libs/libgit2/libgit2-0.26.2.ebuild [new file with mode: 0644]

index 1d84cb549282d11bd65d2672cfddf66ea99e2603..b65ec03c4bc1027a2ffb418034b626b587ba41b1 100644 (file)
@@ -1 +1,2 @@
 DIST libgit2-0.26.0.tar.gz 4697149 BLAKE2B 468e679bd7093004fb19a7947102d09bb90c653f3957615ce5468fe4c602f61804877072445a90447d83c70277529d02762cd3f35d0879708ea8355c44fe3456 SHA512 988c616c99637f2c1f80c498de34820296b78c0601669475eba9d194490cfd2047131987e63a799599277893e5741f9bcc226ffa594327356047ed563f07d346
+DIST libgit2-0.26.2.tar.gz 4706513 BLAKE2B e11a7043d3f1b0a13d04129b7052d60beb401bc87f583f63dc514251dda001b622d8a7b5c7b65b8d6364244e4b15e09bd4ef789b120ef13214cd0430af8c76c1 SHA512 4601b4a09f2c70b41361eab5549d3f758ab5a62742e4ae0b07df0cf4f8d7b66a2eae09a1db410afcce0f6436162dbc4f8cbe97b08de1807960ddfce02e5d695b
diff --git a/dev-libs/libgit2/libgit2-0.26.2.ebuild b/dev-libs/libgit2/libgit2-0.26.2.ebuild
new file mode 100644 (file)
index 0000000..cf73d59
--- /dev/null
@@ -0,0 +1,75 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit cmake-utils multilib
+
+if [[ ${PV} == "9999" ]] ; then
+       EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"
+       inherit git-r3
+else
+       SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+       KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86 ~ppc-macos"
+fi
+
+DESCRIPTION="A linkable library for Git"
+HOMEPAGE="https://libgit2.github.com/"
+
+LICENSE="GPL-2-with-linking-exception"
+SLOT="0/26"
+IUSE="examples gssapi libressl +ssh test +threads trace"
+
+RDEPEND="
+       !libressl? ( dev-libs/openssl:0 )
+       libressl? ( dev-libs/libressl )
+       sys-libs/zlib
+       net-libs/http-parser:=
+       gssapi? ( virtual/krb5 )
+       ssh? ( net-libs/libssh2 )
+"
+DEPEND="${RDEPEND}
+       virtual/pkgconfig
+"
+
+DOCS=( AUTHORS CONTRIBUTING.md CONVENTIONS.md README.md )
+
+src_prepare() {
+       # skip online tests
+       sed -i '/libgit2_clar/s/-ionline/-xonline/' CMakeLists.txt || die
+
+       cmake-utils_src_prepare
+}
+
+src_configure() {
+       local mycmakeargs=(
+               -DLIB_INSTALL_DIR="${EPREFIX}/usr/$(get_libdir)"
+               $(cmake-utils_use_build test CLAR)
+               $(cmake-utils_use_enable trace TRACE)
+               $(cmake-utils_use_use gssapi GSSAPI)
+               $(cmake-utils_use_use ssh SSH)
+               $(cmake-utils_use threads THREADSAFE)
+       )
+       cmake-utils_src_configure
+}
+
+src_test() {
+       if [[ ${EUID} -eq 0 ]] ; then
+               # repo::iterator::fs_preserves_error fails if run as root
+               # since root can still access dirs with 0000 perms
+               ewarn "Skipping tests: non-root privileges are required for all tests to pass"
+       else
+               local TEST_VERBOSE=1
+               cmake-utils_src_test
+       fi
+}
+
+src_install() {
+       cmake-utils_src_install
+
+       if use examples ; then
+               egit_clean examples
+               dodoc -r examples
+               docompress -x /usr/share/doc/${PF}/examples
+       fi
+}