dev-java/jung: EAPI 5 bump. Make use of java-pkg-simple.
authorPatrice Clement <monsieurp@gentoo.org>
Sun, 20 Dec 2015 19:51:29 +0000 (19:51 +0000)
committerPatrice Clement <monsieurp@gentoo.org>
Sun, 20 Dec 2015 20:07:19 +0000 (20:07 +0000)
Package-Manager: portage-2.2.20.1
Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
dev-java/jung/jung-1.7.6-r1.ebuild [new file with mode: 0644]

diff --git a/dev-java/jung/jung-1.7.6-r1.ebuild b/dev-java/jung/jung-1.7.6-r1.ebuild
new file mode 100644 (file)
index 0000000..ae0b0e2
--- /dev/null
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="The Java Universal Network/Graph Framework"
+HOMEPAGE="http://jung.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.zip"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+CDEPEND="
+       dev-java/colt:0
+       dev-java/commons-collections:0"
+
+RDEPEND="
+       ${CDEPEND}
+       >=virtual/jre-1.6"
+
+DEPEND="
+       ${CDEPEND}
+       app-arch/unzip
+       >=virtual/jdk-1.6"
+
+JAVA_SRC_DIR="src/edu"
+
+JAVA_GENTOO_CLASSPATH="
+       colt
+       commons-collections
+"
+
+java_prepare() {
+       java-pkg_clean
+}