dev-python/freezegun-0.3.12-r1: Revbump, cleanup deps a bit
authorPatrick McLean <patrick.mclean@sony.com>
Thu, 5 Dec 2019 04:52:30 +0000 (20:52 -0800)
committerPatrick McLean <chutzpah@gentoo.org>
Thu, 5 Dec 2019 04:53:00 +0000 (20:53 -0800)
Copyright: Sony Interactive Entertainment Inc.
Package-Manager: Portage-2.3.80, Repoman-2.3.19
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
dev-python/freezegun/freezegun-0.3.12-r1.ebuild [moved from dev-python/freezegun/freezegun-0.3.12.ebuild with 86% similarity]

similarity index 86%
rename from dev-python/freezegun/freezegun-0.3.12.ebuild
rename to dev-python/freezegun/freezegun-0.3.12-r1.ebuild
index d33a914e745d63075eb9bdab8cceb8a86216fa50..bef9ce1ee62ae7b8d8f5a4f9b6fbbefaa1d3a5b8 100644 (file)
@@ -38,6 +38,15 @@ PATCHES=(
 
 distutils_enable_tests pytest
 
+python_prepare_all() {
+       sed -r \
+               -e 's:(python-dateutil)>=2.0:\1:' \
+               -e "s:'(python-dateutil)>=[0-9.]+,.+':'\1':" \
+               -i setup.py
+
+       distutils-r1_python_prepare_all
+}
+
 python_prepare() {
        # optional and only works with python3
        if ! python_is_python3; then