net-dns/dnscrypt-proxy: fix vendored source usage
authorGeorgy Yakovlev <gyakovlev@gentoo.org>
Mon, 9 Mar 2020 20:41:08 +0000 (13:41 -0700)
committerGeorgy Yakovlev <gyakovlev@gentoo.org>
Mon, 9 Mar 2020 20:50:19 +0000 (13:50 -0700)
was broken with latest go-module eclass changes

Bug: https://bugs.gentoo.org/711924
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
net-dns/dnscrypt-proxy/dnscrypt-proxy-2.0.39.ebuild

index df223114220555c3ad0613cea74a1505aa907904..bf14276c848120a4c54ec6fdf00fbaf66619a30f 100644 (file)
@@ -34,7 +34,7 @@ PATCHES=( "${FILESDIR}"/config-full-paths-r10.patch )
 
 src_compile() {
        pushd "${PN}" >/dev/null || die
-       go build -buildmode="$(usex pie pie default)" || die
+       go build -v -x -mod=readonly -mod=vendor -buildmode="$(usex pie pie default)" || die
        popd >/dev/null || die
 }