dev-python/svgwrite: Bump to 1.4
authorMichał Górny <mgorny@gentoo.org>
Mon, 18 May 2020 10:31:37 +0000 (12:31 +0200)
committerMichał Górny <mgorny@gentoo.org>
Mon, 18 May 2020 10:32:08 +0000 (12:32 +0200)
Closes: https://bugs.gentoo.org/723628
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/svgwrite/Manifest
dev-python/svgwrite/svgwrite-1.4.ebuild [new file with mode: 0644]

index 92a65acc1d476bff5ccc7fd8f825b74583550ff4..98556f6673dd3d8f0815731555afab90eac8ea5b 100644 (file)
@@ -1 +1,2 @@
 DIST svgwrite-1.3.1.tar.gz 249712 BLAKE2B 3f03f841d4e1bdf3e8d3d47c86301bcc22f205d71d265902f0ccb5a78710815521f34589ce261a463d7e80c6eeaac60d2090895ae1157ab6f20c0f5c21f5e2e2 SHA512 a4d2db34194923055c6e92c0af5540eef767cf8481d7c991b357f5bc77fd1874bba65220e7a7ff3a4da4bd30a49663b6ac514adb2b41cb4b087a7bb64053ac0a
+DIST svgwrite-1.4.tar.gz 251138 BLAKE2B b105fa60ed75628c59b3ad4d0ea32dddf83f618e213ce6974b5db0e93d519e563eb5a9ff5e37012f71c7ce79579ca927acfb8709d2f8e8ad316b04bae8abafcb SHA512 b722fc51c6b3755064942bb6c7ea199ba5902ee37e426962ed24e0b67659e72e8da36cd2516193e2348a939ab2ccd2c5114349ac72d7b9ea52a7b7d68ad1ce74
diff --git a/dev-python/svgwrite/svgwrite-1.4.ebuild b/dev-python/svgwrite/svgwrite-1.4.ebuild
new file mode 100644 (file)
index 0000000..a6ee8c8
--- /dev/null
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit distutils-r1
+
+DESCRIPTION="Python Package to write SVG files"
+HOMEPAGE="https://github.com/mozman/svgwrite"
+SRC_URI="https://github.com/mozman/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+       # fetches from the Internet
+       sed -i -e 's:test_embed_google_web_font:_&:' \
+               tests/test_style.py || die
+       distutils-r1_src_prepare
+}