app-i18n/librime: Delete broken "static-libs" USE flag.
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>
Fri, 28 Jun 2019 17:13:00 +0000 (17:13 +0000)
committerMike Gilbert <floppym@gentoo.org>
Fri, 28 Jun 2019 18:09:23 +0000 (14:09 -0400)
Fixes: https://bugs.gentoo.org/686924
Signed-off-by: Arfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>
Signed-off-by: Mike Gilbert <floppym@gentoo.org>
app-i18n/librime/librime-1.2.9.ebuild
app-i18n/librime/librime-1.3.1.ebuild
app-i18n/librime/librime-1.4.0.ebuild

index 0cee02a76e84ed7fba8a1d0a2e90f0caae57b532..3a095f779484a216b80f6ee307f35ac6ade19aa8 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 2012-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI="6"
@@ -12,7 +12,7 @@ SRC_URI="https://github.com/rime/${PN}/archive/rime-${PV}.tar.gz -> ${P}.tar.gz"
 LICENSE="GPL-3"
 SLOT="0/1"
 KEYWORDS="amd64 ppc ppc64 x86"
-IUSE="static-libs test"
+IUSE="test"
 
 RDEPEND="app-i18n/opencc:=
        dev-cpp/glog:=
@@ -26,7 +26,6 @@ DEPEND="${RDEPEND}
 
 src_configure() {
        local mycmakeargs=(
-               -DBUILD_STATIC=$(usex static-libs)
                -DBUILD_TEST=$(usex test)
                -DBOOST_USE_CXX11=ON
                -DLIB_INSTALL_DIR="${EPREFIX}"/usr/$(get_libdir)
index c0422746cca33ff4d35ae923b55d6cac4c94513c..6adbfbf2ddc8a7df11f7768e16a9756ac72db4ea 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 2012-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI="6"
@@ -12,7 +12,7 @@ SRC_URI="https://github.com/rime/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
 LICENSE="GPL-3"
 SLOT="0/1"
 KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-IUSE="static-libs test"
+IUSE="test"
 
 RDEPEND="app-i18n/opencc:=
        dev-cpp/glog:=
@@ -28,7 +28,6 @@ DOCS=( {CHANGELOG,README}.md )
 
 src_configure() {
        local mycmakeargs=(
-               -DBUILD_STATIC=$(usex static-libs)
                -DBUILD_TEST=$(usex test)
                -DBOOST_USE_CXX11=ON
                -DLIB_INSTALL_DIR="${EPREFIX}"/usr/$(get_libdir)
index 17878776ea87c7b2891cf55f20e3343ad3c019ea..0b7c3762df213d1fc2d0680d0808d5d188d66945 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 2012-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -12,7 +12,7 @@ SRC_URI="https://github.com/rime/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
 LICENSE="GPL-3"
 SLOT="0/1"
 KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-IUSE="static-libs test"
+IUSE="test"
 
 RDEPEND="app-i18n/opencc:=
        dev-cpp/glog:=
@@ -28,7 +28,6 @@ DOCS=( {CHANGELOG,README}.md )
 
 src_configure() {
        local mycmakeargs=(
-               -DBUILD_STATIC=$(usex static-libs)
                -DBUILD_TEST=$(usex test)
                -DBOOST_USE_CXX11=ON
                -DLIB_INSTALL_DIR="${EPREFIX}"/usr/$(get_libdir)