Add jemalloc-4.2.0 update, drop force-gtk2 useflag from mozconfig-v6.46.eclass
authorJory A. Pratt <anarchy@gentoo.org>
Sun, 5 Jun 2016 21:30:59 +0000 (16:30 -0500)
committerJory A. Pratt <anarchy@gentoo.org>
Sun, 5 Jun 2016 22:03:58 +0000 (17:03 -0500)
dev-libs/jemalloc/Manifest
dev-libs/jemalloc/jemalloc-4.2.0.ebuild [new file with mode: 0644]
eclass/mozconfig-v6.46.eclass

index 9a352034f2934bef6931d68381fa10028c1b5ae9..0a640182579a07ccdc35e0076d46790c9af962ee 100644 (file)
@@ -3,3 +3,4 @@ DIST jemalloc-3.3.1.tar.bz2 252997 SHA256 35c433cc1df5cdf9eb58b7980338552fc1d7aa
 DIST jemalloc-3.6.0.tar.bz2 338964 SHA256 e16c2159dd3c81ca2dc3b5c9ef0d43e1f2f45b04548f42db12e7c12d7bdf84fe SHA512 ebe7c64558a87a735b5906d5cb7527c241664eeae7328538675a12eabe7a1004be0f8766a3bd2a78e61334b196ca7ffc0ee8b8ff59167922a35f126cd1e76e43 WHIRLPOOL d5452005951b10d9d529349481779d79361ec8d8ac1f36f4b54408b5e0184f35d79fee8378188d98f1b8e41ae13557a2cf41ab849b68856ba69f33870fe6e980
 DIST jemalloc-4.0.4.tar.bz2 391483 SHA256 3fda8d8d7fcd041aa0bebbecd45c46b28873cf37bd36c56bf44961b36d0f42d0 SHA512 93be0551a80d5f5dc3a1044ef3d5f06c5ce65f3c1fd753743ee64340b841fc2d7902178774ab71eaa633f68abad44109870eb84159679fdc8ce6d93db3a53112 WHIRLPOOL c8bc1a81555b30ff519fda90bfbcfcdb6c9e370ba7478bca17058e58e08c36d20a1995ab12d5374d4edb9cdd2469748517a6f1795a24667c5f798c4c0c756a9c
 DIST jemalloc-4.1.0.tar.bz2 412900 SHA256 fad06d714f72adb4265783bc169c6d98eeb032d57ba02d87d1dcb4a2d933ec8e SHA512 12433101936a104115d8d93991b4849daf897bd39d6c28b1235215c7abc627163a70d19259fb1f2eeb0cdd66cfe889c2e40eb77dccee6debd73b1a4313d0de73 WHIRLPOOL 0305d1cc715c565749c5e9c2de396d349c0d79513da80b461324c82f880c6a070a932cea19802ac809810fe01690dcb24047914f937ddf167a990cf7b4110f0c
+DIST jemalloc-4.2.0.tar.bz2 430964 SHA256 b216ddaeb901697fe38bd30ea02d7505a4b60e8979092009f95cfda860d46acb SHA512 a6963ad62830472c8b85d0184d24fdd07039e41d02a7bd5177618f7b9f936c658b836ea74e4d2b771f12eea8dc9892363991cf5fab7b19a42871a8cbeb2ef1c4 WHIRLPOOL 94c030bb70b2a1538af2037ce9708e761f801b2ca86101dbe80a839757af6c7ebbc7d032eadf202f84f33cc88ebca6e0263c747d746fe4a7fc0598e9d3b278ec
diff --git a/dev-libs/jemalloc/jemalloc-4.2.0.ebuild b/dev-libs/jemalloc/jemalloc-4.2.0.ebuild
new file mode 100644 (file)
index 0000000..8c320ea
--- /dev/null
@@ -0,0 +1,47 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit toolchain-funcs multilib-build
+
+DESCRIPTION="Jemalloc is a general-purpose scalable concurrent allocator"
+HOMEPAGE="http://www.canonware.com/jemalloc/"
+SRC_URI="http://www.canonware.com/download/${PN}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0/2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="debug static-libs stats"
+HTML_DOCS=( doc/jemalloc.html )
+PATCHES=( "${FILESDIR}/${PN}-3.5.1-strip-optimization.patch"
+       "${FILESDIR}/${PN}-3.5.1_fix_html_install.patch"
+)
+MULTILIB_WRAPPED_HEADERS=( /usr/include/jemalloc/jemalloc.h )
+# autotools-utils.eclass auto-adds configure options when static-libs is in IUSE
+# but jemalloc doesn't implement them in its configure; need this here to
+# supress the warnings until automagic is removed from the eclass
+QA_CONFIGURE_OPTIONS="--enable-static --disable-static --enable-shared --disable-shared"
+
+multilib_src_configure() {
+       ECONF_SOURCE="${S}" econf \
+               $(use_enable debug)
+               $(use_enable stats)
+}
+
+multilib_src_install() {
+       # Copy man file which the Makefile looks for
+       cp "${S}/doc/jemalloc.3" "${BUILD_DIR}/doc" || die
+       emake DESTDIR="${D}" install
+}
+
+multilib_src_install_all() {
+       if [[ ${CHOST} == *-darwin* ]] ; then
+               # fixup install_name, #437362
+               install_name_tool \
+                       -id "${EPREFIX}"/usr/$(get_libdir)/libjemalloc.1.dylib \
+                       "${ED}"/usr/$(get_libdir)/libjemalloc.1.dylib || die
+       fi
+       use static-libs || find "${ED}" -name '*.a' -delete
+}
index 90b11efd15050aeab6a5d7081507177b9b185b68..0ec1e8a91941a5bf21f2c7aa31cd4c091d79c312 100644 (file)
@@ -62,7 +62,7 @@ inherit flag-o-matic toolchain-funcs mozcoreconf-v3
 # @ECLASS-VARIABLE: MOZCONFIG_OPTIONAL_GTK2ONLY
 # @DESCRIPTION:
 # Set this variable before the inherit line, when an ebuild can provide
-# optional gtk2-only support via IUSE="force-gtk2".
+# optional gtk2-only support via IUSE="gtk2".
 #
 # Note that this option conflicts directly with MOZCONFIG_OPTIONAL_GTK3, both
 # variables cannot be set at the same time and this variable will be ignored if
@@ -138,12 +138,12 @@ if [[ -n ${MOZCONFIG_OPTIONAL_GTK3} ]]; then
        gtk3? ( >=x11-libs/gtk+-3.4.0:3 )"
 elif [[ -n ${MOZCONFIG_OPTIONAL_GTK2ONLY} ]]; then
        if [[ ${MOZCONFIG_OPTIONAL_GTK2ONLY} = "enabled" ]]; then
-               IUSE+=" +force-gtk2"
+               IUSE+=" +gtk2"
        else
-               IUSE+=" force-gtk2"
+               IUSE+=" gtk2"
        fi
        RDEPEND+="
-       !force-gtk2? ( >=x11-libs/gtk+-3.4.0:3 )"
+       !gtk2? ( >=x11-libs/gtk+-3.4.0:3 )"
 fi
 if [[ -n ${MOZCONFIG_OPTIONAL_QT5} ]]; then
        inherit qmake-utils
@@ -200,9 +200,9 @@ REQUIRED_USE="
 [[ -n ${MOZCONFIG_OPTIONAL_GTK3} ]] && [[ -n ${MOZCONFIG_OPTIONAL_QT5} ]] && \
        REQUIRED_USE+=" ?? ( gtk3 qt5 )"
 
-# only one of force-gtk2 or qt5 should be permitted to be selected, since only one will be used.
+# only one of gtk2 or qt5 should be permitted to be selected, since only one will be used.
 [[ -n ${MOZCONFIG_OPTIONAL_GTK2ONLY} ]] && [[ -n ${MOZCONFIG_OPTIONAL_QT5} ]] && \
-       REQUIRED_USE+=" ?? ( force-gtk2 qt5 )"
+       REQUIRED_USE+=" ?? ( gtk2 qt5 )"
 
 # @FUNCTION: mozconfig_config
 # @DESCRIPTION:
@@ -299,10 +299,10 @@ mozconfig_config() {
                fi
        fi
        if [[ -n ${MOZCONFIG_OPTIONAL_GTK2ONLY} ]]; then
-               if ! use force-gtk2 ; then
+               if ! use gtk2 ; then
                        toolkit="cairo-gtk3"
                else
-                       toolkit_comment="force-gtk2 use flag"
+                       toolkit_comment="gtk2 use flag"
                fi
        fi
        if [[ -n ${MOZCONFIG_OPTIONAL_QT5} ]]; then