dev-python/cssselect: Remove old
authorMichał Górny <mgorny@gentoo.org>
Sun, 26 Jan 2020 16:56:16 +0000 (17:56 +0100)
committerMichał Górny <mgorny@gentoo.org>
Sun, 26 Jan 2020 17:11:35 +0000 (18:11 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/cssselect/Manifest
dev-python/cssselect/cssselect-0.9.1.ebuild [deleted file]
dev-python/cssselect/cssselect-1.0.1.ebuild [deleted file]
dev-python/cssselect/cssselect-1.0.3.ebuild [deleted file]

index 666b6aa8270b91d270afe69587f2e075cbb07949..aac0457f118f60c80d4a71615b8c179324943c9a 100644 (file)
@@ -1,4 +1 @@
-DIST cssselect-0.9.1.tar.gz 32952 BLAKE2B 7f7a78e8085036bed72c2a1a0e4a97cd1988e8d6981ae830f15d5fc03f5fdd43f0caa7b94d2923181f9dc926a6a11e970b3f091178640124286aa680fa023aaf SHA512 c4cd2c8d6fbfa99b836554685dd59e1e794e1fab06fcf4419a226b0608a05d58be5af54e507003f2a233a22f03d59d3d63c0bf19b3314f15c95ab3ce5f4db6cc
-DIST cssselect-1.0.1.tar.gz 21849 BLAKE2B cfe3637746329db224a44b680cda044238fa831ed0d05cf3484be6181de13bf8660330362626ddc03c7284a80e7c4a814bba293dfdca07a529d9c0c7163c95d2 SHA512 060c4b8d427a935b851b4b20d10ef89b9d6f685692b7144afc8f848e318abaa182ed60538355ea3f25050e358f24904fa0d9c01fe77e3d2428e2ef2a825e2928
-DIST cssselect-1.0.3.tar.gz 34027 BLAKE2B fff15a50d26ce83a0480020e54d00a027a7f21ca2c4c45d5552c6b4c19f7be21c390650c4befa61b7ae2b63946de88945deb488ebd6c7f7fc470950dab233671 SHA512 08feb3a515cc75089657a508cd1a80c6aaa97d710f27e99f9e749a1519adc13c5540134c6a4e0d7f548b022b8bd23dcbe360530d2329c5da36e43aca1f9627d1
 DIST cssselect-1.1.0.tar.gz 35516 BLAKE2B b4480ad4335ba15ae8a2ae758ff942865a5b61de68b3b00fb59d517b1dacfce1cd817280e4aac562dbf829f90601a56220f01d99aecbc502420b9102e50c46ca SHA512 b33bca6a026f4de37b75606fd238dbd170b57d06288fbff3ea97ce79685a99af275fb8522b04ea9d6693aba5a18541d70b657191fdad881be79718bcf2e7655c
diff --git a/dev-python/cssselect/cssselect-0.9.1.ebuild b/dev-python/cssselect/cssselect-0.9.1.ebuild
deleted file mode 100644 (file)
index 535ae23..0000000
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_6 )
-
-inherit distutils-r1
-
-DESCRIPTION="parses CSS3 Selectors and translates them to XPath 1.0"
-HOMEPAGE="https://cssselect.readthedocs.io/en/latest/
-       https://pypi.org/project/cssselect/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ia64 ppc ppc64 s390 ~sh sparc x86"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-DEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
-       test? ( dev-python/lxml[${PYTHON_USEDEP}] )"
-RDEPEND=""
-
-python_prepare_all() {
-       # prevent non essential d'load of files in doc build
-       sed -e 's:intersphinx_:#&:' -i docs/conf.py || die
-       distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
-       if use doc ; then
-               "${PYTHON}" setup.py build_sphinx || die
-       fi
-}
-
-python_test() {
-       "${PYTHON}" ${PN}/tests.py -v || die "Tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
-       use doc && local HTML_DOCS=( docs/_build/html/. )
-       distutils-r1_python_install_all
-}
diff --git a/dev-python/cssselect/cssselect-1.0.1.ebuild b/dev-python/cssselect/cssselect-1.0.1.ebuild
deleted file mode 100644 (file)
index 83c87c5..0000000
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_6 )
-
-inherit distutils-r1
-
-DESCRIPTION="parses CSS3 Selectors and translates them to XPath 1.0"
-HOMEPAGE="https://cssselect.readthedocs.io/en/latest/
-       https://pypi.org/project/cssselect/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="doc test"
-
-# No tests.py file in this release.
-# Please check on version bumps if it's still missing.
-RESTRICT="test"
-
-DEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
-       test? ( dev-python/lxml[${PYTHON_USEDEP}] )"
-
-RDEPEND=""
-
-python_prepare_all() {
-       # prevent non essential d'load of files in doc build
-       sed -e 's:intersphinx_:#&:' -i docs/conf.py || die
-       distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
-       if use doc ; then
-               "${PYTHON}" setup.py build_sphinx || die
-       fi
-}
-
-python_test() {
-       "${PYTHON}" ${PN}/tests.py -v || die "Tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
-       use doc && local HTML_DOCS=( docs/_build/html/. )
-       distutils-r1_python_install_all
-}
diff --git a/dev-python/cssselect/cssselect-1.0.3.ebuild b/dev-python/cssselect/cssselect-1.0.3.ebuild
deleted file mode 100644 (file)
index 004a8ab..0000000
+++ /dev/null
@@ -1,27 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{6,7,8} )
-
-inherit distutils-r1
-
-DESCRIPTION="parses CSS3 Selectors and translates them to XPath 1.0"
-HOMEPAGE="https://cssselect.readthedocs.io/en/latest/
-       https://pypi.org/project/cssselect/
-       https://github.com/scrapy/cssselect"
-SRC_URI="https://github.com/scrapy/cssselect/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-DEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       test? ( dev-python/lxml[${PYTHON_USEDEP}] )"
-
-distutils_enable_sphinx docs
-distutils_enable_tests unittest