sys-fs/zfs: bump to 0.8.1
authorGeorgy Yakovlev <gyakovlev@gentoo.org>
Fri, 14 Jun 2019 21:52:04 +0000 (14:52 -0700)
committerGeorgy Yakovlev <gyakovlev@gentoo.org>
Fri, 14 Jun 2019 22:07:35 +0000 (15:07 -0700)
Package-Manager: Portage-2.3.67, Repoman-2.3.14
Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
sys-fs/zfs/Manifest
sys-fs/zfs/zfs-0.8.1.ebuild [new file with mode: 0644]

index 825a5d4f3978829a253886c6777dc14268b7332e..d96bcf93180eae307002ecb2f98ebcbae41481dd 100644 (file)
@@ -2,3 +2,4 @@ DIST zfs-0.6.5.11.tar.gz 2521959 BLAKE2B 95b145a26620995343df1a468367b882bc71ab3
 DIST zfs-0.7.12.tar.gz 6565017 BLAKE2B 493df30ecce1f169e02d6c8262ba71cc9e7b01d5b17ce188004f522f0c93943b858434067cba8173ccb3e08cde24a1d3e8a3996b2e852f8bc35251f8c4ab3809 SHA512 278e411eac5fb2a91108671b64521c2bd5c08024d5829e1679d8f243dfc3c6317363ed9c79dabfddecf425acb6b3003eeaf4e7d991513cbcae4d2644f5d30bf2
 DIST zfs-0.7.13.tar.gz 6614047 BLAKE2B c59c46287715779eb04d69333b0a417fa9865eb0d61c642b043188c4c97d4eed369f76a48327326ed1d4dd608ff95d91d20d26c80ed0b120a8fcd5f83cea638f SHA512 457d8f110b68c9656194cd3738b216d5d807d680e5cfc6ed1f3cf5ebde67860476387c6b862ba3ba7f972d8945075963e6c325543ab84468e3eff5dbce68476e
 DIST zfs-0.8.0.tar.gz 9084737 BLAKE2B c3095ca07b7c36fa204274be1166fd244894de70b97a11da32606b08e9bb150bc1326ac8424d5c001eb33d2d94e214d3944ddfce885844885c55291a82f11a2f SHA512 ba29f1644ec6807f4cad574e4950e56026316c3d405c9fc40a63ab34c2400d508521b09f656ac97898e5feaca5e0b259d9d4d85f75a4b1782a9db13d3b14cdc6
+DIST zfs-0.8.1.tar.gz 8668360 BLAKE2B f18268656381c20af6bd18421636a1c56633c7eafaf91b1308d15508d5f4bdcfa5dfbb4e09d0302ac3de9d6a4f69718fe9c3d083ed5b3ab2a32c6fb7a1db624b SHA512 1fb3957f65dbe94edaffcedb5b2694390dc14e472c11f7e63184a9ea6a774e79a43d47a2d789b7ced233fc67c76583bf7d5c1bda0692bb07929673e2a57f4667
diff --git a/sys-fs/zfs/zfs-0.8.1.ebuild b/sys-fs/zfs/zfs-0.8.1.ebuild
new file mode 100644 (file)
index 0000000..129f348
--- /dev/null
@@ -0,0 +1,250 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_OPTIONAL=1
+PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
+
+inherit bash-completion-r1 flag-o-matic linux-info linux-mod distutils-r1 systemd toolchain-funcs udev
+
+DESCRIPTION="Userland utilities for ZFS Linux kernel module"
+HOMEPAGE="https://zfsonlinux.org/"
+
+if [[ ${PV} == "9999" ]] ; then
+       inherit autotools git-r3
+       EGIT_REPO_URI="https://github.com/zfsonlinux/zfs.git"
+else
+       SRC_URI="https://github.com/zfsonlinux/${PN}/releases/download/${P}/${P}.tar.gz"
+       KEYWORDS="~amd64"
+fi
+
+LICENSE="BSD-2 CDDL MIT"
+SLOT="0"
+IUSE="custom-cflags debug kernel-builtin python +rootfs test-suite static-libs"
+
+COMMON_DEPEND="
+       ${PYTHON_DEPS}
+       net-libs/libtirpc
+       sys-apps/util-linux[static-libs?]
+       sys-libs/zlib[static-libs(+)?]
+       virtual/awk
+       python? (
+               virtual/python-cffi[${PYTHON_USEDEP}]
+       )
+"
+
+BDEPEND="${COMMON_DEPEND}
+       virtual/pkgconfig
+       python? (
+               dev-python/setuptools[${PYTHON_USEDEP}]
+       )
+"
+
+RDEPEND="${COMMON_DEPEND}
+       !=sys-apps/grep-2.13*
+       !kernel-builtin? ( ~sys-fs/zfs-kmod-${PV} )
+       !sys-fs/zfs-fuse
+       !prefix? ( virtual/udev )
+       sys-fs/udev-init-scripts
+       rootfs? (
+               app-arch/cpio
+               app-misc/pax-utils
+               !<sys-boot/grub-2.00-r2:2
+               !<sys-kernel/genkernel-3.5.1.1
+               !<sys-kernel/genkernel-next-67
+               !<sys-kernel/bliss-initramfs-7.1.0
+               !<sys-kernel/dracut-044-r1
+       )
+       test-suite? (
+               sys-apps/util-linux
+               sys-devel/bc
+               sys-block/parted
+               sys-fs/lsscsi
+               sys-fs/mdadm
+               sys-process/procps
+               virtual/modutils
+       )
+"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RESTRICT="test"
+
+PATCHES=( "${FILESDIR}/bash-completion-sudo.patch" )
+
+pkg_setup() {
+       if use kernel_linux && use test-suite; then
+               linux-info_pkg_setup
+
+               if  ! linux_config_exists; then
+                       ewarn "Cannot check the linux kernel configuration."
+               else
+                       if use test-suite; then
+                               if linux_chkconfig_present BLK_DEV_LOOP; then
+                                       eerror "The ZFS test suite requires loop device support enabled."
+                                       eerror "Please enable it:"
+                                       eerror "    CONFIG_BLK_DEV_LOOP=y"
+                                       eerror "in /usr/src/linux/.config or"
+                                       eerror "    Device Drivers --->"
+                                       eerror "        Block devices --->"
+                                       eerror "            [X] Loopback device support"
+                               fi
+                       fi
+               fi
+       fi
+}
+
+src_prepare() {
+       default
+
+       if [[ ${PV} == "9999" ]]; then
+               eautoreconf
+       else
+               # Set revision number
+               sed -i "s/\(Release:\)\(.*\)1/\1\2${PR}-gentoo/" META || die "Could not set Gentoo release"
+       fi
+
+       # Update paths
+       sed -e "s|/sbin/lsmod|/bin/lsmod|" \
+               -e "s|/usr/bin/scsi-rescan|/usr/sbin/rescan-scsi-bus|" \
+               -e "s|/sbin/parted|/usr/sbin/parted|" \
+               -i scripts/common.sh.in || die
+
+       if use python; then
+               pushd contrib/pyzfs >/dev/null || die
+               distutils-r1_src_prepare
+               popd >/dev/null || die
+       fi
+}
+
+src_configure() {
+       use custom-cflags || strip-flags
+
+       local myconf=(
+               --bindir="${EPREFIX}/bin"
+               --enable-systemd
+               --enable-sysvinit
+               --localstatedir="${EPREFIX}/var"
+               --sbindir="${EPREFIX}/sbin"
+               --with-config=user
+               --with-dracutdir="${EPREFIX}/usr/lib/dracut"
+               --with-linux="${KV_DIR}"
+               --with-linux-obj="${KV_OUT_DIR}"
+               --with-udevdir="$(get_udevdir)"
+               --with-systemdunitdir="$(systemd_get_systemunitdir)"
+               --with-systemdpresetdir="${EPREFIX}/lib/systemd/system-preset"
+               $(use_enable debug)
+               $(use_enable python pyzfs)
+       )
+
+       econf "${myconf[@]}"
+}
+
+src_compile() {
+       default
+       if use python; then
+               pushd contrib/pyzfs >/dev/null || die
+               distutils-r1_src_compile
+               popd >/dev/null || die
+       fi
+}
+
+src_install() {
+       default
+
+       gen_usr_ldscript -a uutil nvpair zpool zfs zfs_core
+
+       use test-suite || rm -rf "${ED}/usr/share/zfs"
+
+       dobashcomp contrib/bash_completion.d/zfs
+       bashcomp_alias zfs zpool
+
+       # strip executable bit from conf.d file
+       fperms 0644 /etc/conf.d/zfs
+
+       if use python; then
+               pushd contrib/pyzfs >/dev/null || die
+               distutils-r1_src_install
+               popd >/dev/null || die
+       fi
+
+       # enforce best available python implementation
+       python_setup
+       python_fix_shebang "${ED}/bin"
+}
+
+pkg_postinst() {
+       if has_version "<=sys-kernel/genkernel-3.5.3.3"; then
+               einfo "genkernel version 3.5.3.3 and earlier does NOT support"
+               einfo " unlocking pools with native zfs encryption enabled at boot"
+               einfo " use dracut or genkernel-9999 if you requre this functionality"
+       fi
+
+       if ! use kernel-builtin && [[ ${PV} = "9999" ]]; then
+               einfo "Adding ${P} to the module database to ensure that the"
+               einfo "kernel modules and userland utilities stay in sync."
+               update_moduledb
+       fi
+
+       if [[ -e "${EROOT}/etc/runlevels/boot/zfs" ]]; then
+               einfo 'The zfs boot script has been split into the zfs-import,'
+               einfo 'zfs-mount and zfs-share scripts.'
+               einfo
+               einfo 'You had the zfs script in your boot runlevel. For your'
+               einfo 'convenience, it has been automatically removed and the three'
+               einfo 'scripts that replace it have been configured to start.'
+               einfo 'The zfs-import and zfs-mount scripts have been added to the boot'
+               einfo 'runlevel while the zfs-share script is in the default runlevel.'
+
+               rm "${EROOT}/etc/runlevels/boot/zfs"
+               ln -snf "${EROOT}/etc/init.d/zfs-import" \
+                       "${EROOT}/etc/runlevels/boot/zfs-import"
+               ln -snf "${EROOT}/etc/init.d/zfs-mount" \
+                       "${EROOT}/etc/runlevels/boot/zfs-mount"
+               ln -snf "${EROOT}/etc/init.d/zfs-share" \
+                       "${EROOT}/etc/runlevels/default/zfs-share"
+       else
+               [[ -e "${EROOT}/etc/runlevels/boot/zfs-import" ]] || \
+                       einfo "You should add zfs-import to the boot runlevel."
+               [[ -e "${EROOT}/etc/runlevels/boot/zfs-mount" ]]|| \
+                       einfo "You should add zfs-mount to the boot runlevel."
+               [[ -e "${EROOT}/etc/runlevels/default/zfs-share" ]] || \
+                       einfo "You should add zfs-share to the default runlevel."
+       fi
+
+       if [[ -e "${EROOT}/etc/runlevels/default/zed" ]]; then
+               einfo 'The downstream OpenRC zed script has replaced by the upstream'
+               einfo 'OpenRC zfs-zed script.'
+               einfo
+               einfo 'You had the zed script in your default runlevel. For your'
+               einfo 'convenience, it has been automatically removed and the zfs-zed'
+               einfo 'script that replaced it has been configured to start.'
+
+               rm "${EROOT}/etc/runlevels/boot/zed"
+               ln -snf "${EROOT}/etc/init.d/zfs-zed" \
+                       "${EROOT}/etc/runlevels/default/zfs-zed"
+       else
+               [[ -e "${EROOT}/etc/runlevels/default/zfs-zed" ]] || \
+                       einfo "You should add zfs-zed to the default runlevel."
+       fi
+
+       if [[ -e "${EROOT}/etc/runlevels/shutdown/zfs-shutdown" ]]; then
+               einfo "The zfs-shutdown script is obsolete. Removing it from runlevel."
+               rm "${EROOT}/etc/runlevels/shutdown/zfs-shutdown"
+       fi
+
+       systemd_reenable zfs-zed.service
+       systemd_reenable zfs-import-cache.service
+       systemd_reenable zfs-import-scan.service
+       systemd_reenable zfs-mount.service
+       systemd_reenable zfs-share.service
+       systemd_reenable zfs-import.target
+       systemd_reenable zfs.target
+}
+
+pkg_postrm() {
+       if ! use kernel-builtin && [[ ${PV} == "9999" ]]; then
+               remove_moduledb
+       fi
+}