x11-wm/aewm: Fix CFLAGS=-fno-common
authorJeroen Roovers <jer@gentoo.org>
Fri, 31 Jan 2020 22:30:43 +0000 (23:30 +0100)
committerJeroen Roovers <jer@gentoo.org>
Fri, 31 Jan 2020 22:31:29 +0000 (23:31 +0100)
Package-Manager: Portage-2.3.86, Repoman-2.3.20
Closes: https://bugs.gentoo.org/707680
Signed-off-by: Jeroen Roovers <jer@gentoo.org>
x11-wm/aewm/aewm-1.3.12-r1.ebuild
x11-wm/aewm/files/aewm-1.3.12-fno-common.patch [new file with mode: 0644]

index c0d52983ed896544e133f641dd213486855ade79..3efbc6c7a7edec23a14831500c784cc7373e1472 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
@@ -26,6 +26,7 @@ DEPEND="
 "
 PATCHES=(
        "${FILESDIR}"/${P}-r1-gentoo.patch
+       "${FILESDIR}"/${P}-fno-common.patch
 )
 
 src_compile() {
diff --git a/x11-wm/aewm/files/aewm-1.3.12-fno-common.patch b/x11-wm/aewm/files/aewm-1.3.12-fno-common.patch
new file mode 100644 (file)
index 0000000..e885161
--- /dev/null
@@ -0,0 +1,25 @@
+--- aedesk.c
++++ b/aedesk.c
+@@ -11,10 +11,6 @@
+ #define UMOD(x, y) ((((long)(x) % (long)(y)) + (y)) % (y))
+-Display *dpy;
+-Window root;
+-Atom net_cur_desk, net_num_desks;
+-
+ static unsigned long parse_desk(char *spec);
+ int main(int argc, char **argv)
+--- aepanel.c
++++ b/aepanel.c
+@@ -36,9 +36,6 @@
+ void sig_handler(int);
+ void set_strut(Window, strut_t *);
+-Atom net_wm_strut;
+-Atom net_wm_strut_partial;
+-Atom net_wm_wintype;
+ Atom net_wm_wintype_dock;
+ #define NAME_SIZE 48