dev-libs/weston: Stop building simple dmabuf clients.
authorMatt Turner <mattst88@gentoo.org>
Fri, 3 Mar 2017 04:24:32 +0000 (20:24 -0800)
committerMatt Turner <mattst88@gentoo.org>
Fri, 3 Mar 2017 04:24:54 +0000 (20:24 -0800)
dev-libs/weston/weston-1.11.0.ebuild
dev-libs/weston/weston-9999.ebuild

index ee12bcfd59940359a2b18b93667e13b7764ef857..9f40f4f81669fdc57540d3078dab6d59565552c1 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=5
@@ -27,8 +27,7 @@ fi
 LICENSE="MIT CC-BY-SA-3.0"
 SLOT="0"
 
-IUSE_VIDEO_CARDS="video_cards_intel video_cards_v4l"
-IUSE="colord dbus +drm editor examples fbdev +gles2 headless ivi jpeg lcms rdp +resize-optimization rpi +launch screen-sharing static-libs +suid systemd test unwind wayland-compositor webp +X xwayland ${IUSE_VIDEO_CARDS}"
+IUSE="colord dbus +drm editor examples fbdev +gles2 headless ivi jpeg lcms rdp +resize-optimization rpi +launch screen-sharing static-libs +suid systemd test unwind wayland-compositor webp +X xwayland"
 
 REQUIRED_USE="
        drm? ( gles2 )
@@ -131,10 +130,10 @@ src_configure() {
                $(use_enable systemd systemd-notify) \
                $(use_enable xwayland) \
                $(use_enable xwayland xwayland-test) \
-               $(use_enable video_cards_intel simple-dmabuf-intel-client) \
-               $(use_enable video_cards_v4l simple-dmabuf-v4l-client) \
                $(use_with jpeg) \
                $(use_with webp) \
+               --disable-simple-dmabuf-intel-client \
+               --disable-simple-dmabuf-v4l-client \
                ${myconf}
 }
 
index e4c51c0b873d2fb8940ab9b0e527031065e50856..253af5431859730dd47486fe34739048d070934d 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=5
@@ -27,8 +27,7 @@ fi
 LICENSE="MIT CC-BY-SA-3.0"
 SLOT="0"
 
-IUSE_VIDEO_CARDS="video_cards_intel video_cards_v4l"
-IUSE="colord dbus +drm editor examples fbdev +gles2 headless ivi jpeg lcms rdp +resize-optimization rpi +launch screen-sharing static-libs +suid systemd test unwind wayland-compositor webp +X xwayland ${IUSE_VIDEO_CARDS}"
+IUSE="colord dbus +drm editor examples fbdev +gles2 headless ivi jpeg lcms rdp +resize-optimization rpi +launch screen-sharing static-libs +suid systemd test unwind wayland-compositor webp +X xwayland"
 
 REQUIRED_USE="
        drm? ( gles2 )
@@ -131,10 +130,10 @@ src_configure() {
                $(use_enable systemd systemd-notify) \
                $(use_enable xwayland) \
                $(use_enable xwayland xwayland-test) \
-               $(use_enable video_cards_intel simple-dmabuf-intel-client) \
-               $(use_enable video_cards_v4l simple-dmabuf-v4l-client) \
                $(use_with jpeg) \
                $(use_with webp) \
+               --disable-simple-dmabuf-intel-client \
+               --disable-simple-dmabuf-v4l-client \
                ${myconf}
 }